Welcome to the PHP File Uploader Documentation

Welcome to the documentation for PHP File Uploader, the world’s leading file upload component for PHP!

PHP File Uploader is an easy to use, hi-performance File Upload Control which allows you to upload files to web server without refreshing the page.

It allows you select and upload multiple files and cancel running uploads, add new files during uploading.

The look and feel of file upload controls can be customized to seamlessly blend into your website design.

Top features and Benefits

  • Select multiple files at once when sending
    PHP File Uploader allows you to select and upload multiple files at once rather than having to select and upload each file individually.
  • Client side validation of the file size/type before uploading
    Client side validation of file size/types prior to uploading the files to a server to increase usability and reduce consumption of network and server resources.
  • Hi-Performance with optimized memory usage
    By streaming uploads directly to an output stream, rather than loading them into memory, PHP File Uploader achieves a level of scalability and performance impossible to reach with PHP's built-in functionality.
  • Provides rich progress and status information during the upload
    PHP File Uploader has a real time progress bar which keeps track of every file upload. It offers an accurate and detailed progress indicator to end-users. It also gives end-users the ability to cancel uploads in progress.
  • Powerful approaches to uploading files without refreshing the page
    Ever wanted to upload files using AJAX like in GMAIL, without reloading the page?
  • Asynchronous file upload
    This means that the file is uploaded in the background, allowing user to still use the page while the file is being uploaded.

© 2003-2010 CuteSoft.Net. All rights reserved.


Features -- PHP File Upload

PHP File Uploader

Features

Features |
Select multiple files for upload PHP File Uploader allows you to select and upload multiple files at once rather than having to select and upload each file individually. | check
Client side validation of the file size/type before uploading Client side validation of file size/types prior to uploading the files to a server to increase usability and reduce consumption of network and server resources. | check
Supports AJAX Uploads without PostBack PHP File Uploader allows you to upload files to web server without refreshing the page. | check
Allows uploads to be cancelled by end-users With PHP File Uploader, end-users can easily cancel upload process at any time. | check
Real time progress bar PHP File Uploader has real time progress bar which keeps track of every file upload and allows end-users to watch how much of your file has been uploaded. | check
Persist uploaded file through postback PHP File Uploader can hold an object temporarily and you can save it anytime you want. | check
Automatic File Validation PHP File Uploader automatically validate the size, extension and the file name of the uploaded files. | check
Large File Upload PHP File Uploader allows you to upload large files (up to 2GB) to a server with the low server memory consumption. | check
Simplified application integration and development PHP File Uploader includes a variety of classes and components which allow complete control over the uploading process. | check
Customizable Appearance The look and feel of File Upload controls can be customized to seamlessly blend into your website design. | check
Cross platform, Cross browsers Runs on PHP 5.0, supports all major browsers; If you attempt to use PHP File Uploader using a downlevel browser it will display a regular upload control. | check
Asynchronous file upload Web page hosting your application remains perfectly responsive and usable throughout the transfer. This allows the user to work on other part of the page while the uploading is in progress. | check
This control is also available for ASP.NET!

Ajax Uploader for .NET


Screenshot -- PHP File Upload

PHP File Uploader

Screenshot

Selecting multiple files

This control is also available for ASP.NET!

Ajax Uploader for .NET


FAQ -- PHP File Upload

PHP File Uploader

FAQ

Sale FAQ

  • Is it possible to try PHP File Uploader before I buy it?
  • Do you offer non-profit or educational organisation discounts?
  • How often are product updates released?
  • How do I receive the product after my purchase?
  • Is the license a life time license? Do I have to pay any additional fees?
  • Do you have any additional methods of payment besides credit card or PayPal?
  • Can I suggest new features?
  • PHP File Uploader Licensing Explained

Functionality FAQ

  • What is PHP File Uploader?
  • What are the limitations of the Evaluation version?
  • Does this product require users to download a browser plug-in?
  • Can PHP File Uploader be easily translated into various languages?
  • Can I change the look and feel of an Upload control or Progress Panel?
  • Is it possible to upload multiple files at the same time?
  • How do I handle a large file upload?
  • What's the maximum size for an upload?
Is it possible to try PHP File Uploader before I buy it?

Yes. Simply click here to download an evaluation version of PHP File Uploader software now. There is no charge. Put PHP File Uploader to the test in your own specific applications.
top
Do you offer non-profit or educational organisation discounts?

Yes, we offer discount to non-profit organization depending on the organizations line of work.
top
How often are product updates released?

Product major version updates are released generally every year. Minor version updates are released every 3-4 months. CuteSoft offers product free minor version upgrades.
top
How do I receive the product after my purchase?

Upon purchase, you will receive an instant notification via email with the download details of your product.
top
Is the license a life time license? Do I have to pay any additional fees?

The license you purchase is a lifetime license, and you do NOT need to pay license fees at any time after your purchase. There are no additional monthly or yearly fees to use the software.
top
Do you have any additional methods of payment besides credit card or PayPal?

We accept both check and direct wire transfers. For more information regarding these forms of payment, please contact us.
top
Can I suggest new features?

Absolutely, We love customer input, ideas, and suggestions. Please feel free to contact us anytime with your feature suggestion, or post in our forums.
top
PHP File Uploader Licensing Explained

This following article describes our licensing policy for the PHP File Uploader.

PHP File Uploader Licensing Info
top
What is PHP File Uploader?

PHP File Uploader is an easy to use, hi-performance File Upload Control which allows you to upload files to web server without refreshing the page.

It allows you select and upload multiple files and cancel running uploads, add new files during uploading.

The look and feel of file upload controls can be customized to seamlessly blend into your website design.
top
What are the limitations of the Evaluation version?

All features work the same as they do in the full version. The evaluation version using a temp license file which will expire in about 30 dasy. Once you place the order, you’ll will receive your own license file.
top
Does this product require users to download a browser plug-in?

No, PHP File Uploader is completely self contained and require no outside plug-in's or add-ons.
top
Can PHP File Uploader be easily translated into various languages?

Yes.
top
Can I change the look and feel of an Upload control or Progress Panel?

Yes! The Upload control exposes many Appearance properties that allow you to manipulate the look of the "browse" button and textbox. You can even use custom images so the Upload control can match your website design. The Progress Panel can be extensively modified so that text, progress bars, and the cancel button are independently modified. At runtime you can even issue custom status messages so reporting progress to your end users is tailored to your application.
top
top
Is it possible to upload multiple files at the same time?

Yes, PHP File Uploader allows for uploading multiple files, please check the online demo.
top
How do I handle a large file upload?

By default there is a restriction of 2 Megabytes file upload at a time for PHP. For large files uploading we need to change some settings in php.ini.

  • Locate the php.ini file in the folder your upload script resides in.
  • In the php.ini file, locate and modify the line called ‘upload_max_filesize = 2M’
PHP presents a very versatile and user friendly interface for handling file uploads. The default installation is not capable of working with files greater than 2 Mega Bytes size. Here are some more options for configuring PHP to handle large file transfers.

php.ini settings

The php.ini file contains all the configuration settings for PHP. These can be overridden by directives in apache .htaccess files or even with in the scripts themselves but for the moment let’s just concentrate on the ini file.

This file contains the following settings that we need to modify according to our needs.

  • file_uploads
  • upload_max_filesize
  • max_input_time
  • memory_limit
  • max_execution_time
  • post_max_size
file_uploads
If you set this off, uploading is disabled.

upload_max_filesize and post_max_size
The post_max_size sets the upper limit on the amount of data that a script can accept in this manner. Ideally this value should be larger than the value that you set for upload_max_filesize.

It’s important to realize that upload_max_filesize is the sum of the sizes of all the files that you are uploading. post_max_size is the upload_max_filesize plus the sum of the lengths of all the other fields in the form plus any mime headers that the encoder might include.

memory_limit
When the PHP engine is handling an incoming POST it needs to keep some of the incoming data in memory. Setting too high a value can be very dangerous because if several uploads are being handled concurrently all available memory will be used up and other unrelated scripts that consume a lot of memory might effect the whole server as well.

max_execution_time and max_input_time
These settings define the maximum life time of the script and the time that the script should spend in accepting input. If several mega bytes of data are being transfered max_input_time should be reasonably high. You can override the setting in the ini file for max_input_time by calling the set_time_limit() function in your scripts.

While working with uploading in PHP, consider above settings and options in mind and use these very carefully.

top
What's the maximum size for an upload?

PHP File Uploader is designed to work with up to 2GB files. The reason for the limit is simple - current browsers does not support upload of bigger files than 2GB over internet and IIS also accepts only 2GB files.
Software | Versions | Upload limit
Internet explorer | All versions | 2GB-1
Mozilla Firefox | All versions | 2GB-1
IIS | 1-5 | 2GB-1
IIS | 6 | 4GB-1
ASP | All versions | 2GB-1
top
This control is also available for ASP.NET!

Ajax Uploader for .NET


Requirements -- PHP File Upload

PHP File Uploader

Requirements

PHP File Uploader is a series of PHP scripts and javascript files that should be copied to your web server. It requires the following:

Web Server Requirements

  • Operating System: Linux, Unix, Windows

  • Web Server: Apache Web Server, IIS

  • Scripting Language: PHP 5.0 or above

Supported Browsers

Ajax Uploader supports all major browsers and platforms (both on PC and Mac, where applicable).

Uplevel Browsers:

    • Internet Explorer 5.5+;
    • all Gecko-based browsers - Mozilla 1.0+, FireFox, Netscape 7+;
    • Opera 8.0+.
    • Safari 1.3+

Downlevel browses:

    • It will render as a regular PHP upload control.
This control is also available for ASP.NET!

Ajax Uploader for .NET
Requirements

Server Requirements
Compatible with PHP 5.0+.


License Agreement

This section describes our licensing policy for the PHP File Uploader product.

By using or installing CuteSoft product, you are agreeing to be bound by the terms and conditions of this License Agreement. As used in this License Agreement, "You" shall mean the individual using or installing the Software together with any individual or entity, including but not limited to your employer, on whose behalf you are acting in using or installing the Software.

1. License Grant

CuteSoft grants to you only, the Licensee, the non-exclusive, nontransferable right to use the Software in accordance with the license you purchase. If you are using this product for your employer, this agreement also includes your employer. You may only use the Software on computers for which the Software is licensed. Software that is distributed as shareware or a demo may be used for testing and evaluation purposes only.

Domain License:

A domain license allows use of the Software for all users at a single site hosted on a single web server.
You may also install and use the Software on an unlimited number of developer workstations (but not on a development server) for use in connection with the same single website host name when accessed by the http://localhost/Webapplication

Small Business License:

A small business license allows use of the Software for all users at 10 sites within a single company.

You may also install and use the Software on an unlimited number of developer workstations (but not on a development server) for use in connection with the same single website host name when accessed by the http://localhost/Webapplication

Developer License:

A developer license entitles a single developer to install and use the product on one machine.

Developer licenses apply to software components, control or class libraries that are integrated by developers into their applications. All developer products have royalty free runtimes. This means that you may freely distribute the product with your application.

Developer Team License:

A developer team license entitles 4 developers to install and use the product.

Developer licenses apply to software components, control or class libraries that are integrated by developers into their applications. All developer products have royalty free runtimes. This means that you may freely distribute the product with your application.

Redistribution License:

A Redistribution License allows CuteEditor Control to be distributed within a single commercial application. A Redistribution license entitles unlimited developer to install and use the product.

Enterprise License:

An enterprise License allows use of the Software on Unlimited servers and applications within a single organization. The Enterprise License includes Royalty FREE distribution rights.

Source Code License:

The Source code license includes the full PHP and JavaScript code of the control. It includes all of the benefits of the Enterprise license and Redistributable license and is best for companies that plan to modify the control or simply wish to have access to the code for security reasons.

2. Copyright

NOTE: This Software and the accompanying materials are copyrighted and contain proprietary information. Unauthorized copying of the Software or accompanying materials even if modified, merged, or included with other software, or of the written materials, is expressly forbidden. You may be held legally responsible for any infringement of intellectual property rights that is caused or encouraged by your failure to abide by the terms of this Agreement. You may make copies of the Software solely for backup purposes provided the copyright and trademark notices are reproduced in their entirety on the backup copy. CuteSoft reserves all rights not specifically granted to Licensee. CuteSoft warrants to you that CuteSoft is the sole owner of all patents, copyrights or other applicable intellectual property rights in and to the Software unless otherwise indicated in the documentation for Software. CuteSoft shall defend and hold Licensee harmless from any third party claims for intellectual property infringement for properly licensed Software provided by CuteSoft. The Software and documentation are licensed, not sold, to you. You may not rent, lease, display or distribute copies of the Software to others. You may not disassemble, decompose, reverse engineer, or alter the Software.

3. Warranty & Risks

Although efforts have been made to assure that the Software is date compliant, correct, reliable, and technically accurate, the Software is licensed to you as is and without warranties as to performance of merchantability, fitness for a particular purpose or use, or any other warranties whether expressed or implied. You, your organization and all users of the Software, assume all risks when using it. The manufacturers, distributors and resellers of the Software shall not be liable for any consequential, incidental, punitive or special damages arising out of the use of or inability to use the Software or the provision of or failure to provide support services, even if we have been advised of the possibility of such damages. In any case, the entire liability under any provision of this agreement shall be limited the amount actually paid by you for the.

4. Technical Support, Product Upgrades and Number of Developers

CuteSoft offers free technical support for a period of 90 days from the date of purchase on all licensed Software products. Technical support is not provided to the end user unless each end user has a valid Single User License. CuteSoft offers product free minor version upgrades. If you later upgrade the Software, this agreement will terminate, and all copies of the Software to which it applies must be destroyed.

5. Controlling Law

This License Agreement shall be governed by and construed in accordance with the laws of the Canada.
This control is also available for ASP.NET!

Ajax Uploader for .NET


Deployment PHP File Uploader

PHP File Uploader

Deployment

PHP File Uploader is 100% HTML and JavaScript code on the client, and PHP code on the server, and can be setup on your web server in just 5 minutes, simply by following this setup guide.

1. Deploying Uploader Client files.

The "phpuploader" folder and all file it contains (located in the archive) should be deployed to http://{your site}/{your application}/phpuploader/ on your web site.
2. Adding Uploader into PHP page.
  1. //Step 1: Register Uploader component to your page
  2. <?php require_once "phpuploader/include_phpuploader.php" ?>
  3. <html>
  4. <body>
  5. <form id="form1" method="POST">
  6. <?php
  7. //Step 2: Create Uploader object.
  8. $uploader=new PhpUploader();
  9. //Step 3: Set a unique name to Uploader
  10. $uploader->Name="myuploader";
  11. //Step 4: Render Uploader
  12. $uploader->Render();
  13. ?>
  14. </form>
  15. </body>
  16. </html>
3. Retrieving uploaded file.
  1. <?php
  2. //Gets the GUID of the file based on uploader name
  3. $fileguid=@$_POST["myuploader"];
  4. if($fileguid)
  5. {
  6. //get the uploaded file based on GUID
  7. $mvcfile=$uploader->GetUploadedFile($fileguid);
  8. if($mvcfile)
  9. {
  10. //Gets the name of the file.
  11. echo($mvcfile->FileName);
  12. //Gets the temp file path.
  13. echo($mvcfile->FilePath);
  14. //Gets the size of the file.
  15. echo($mvcfile->FileSize);
  17. //Copys the uploaded file to a new location.
  18. $mvcfile->CopyTo("/uploads");
  19. //Moves the uploaded file to a new location.
  20. $mvcfile->MoveTo("/uploads");
  21. //Deletes this instance.
  22. $mvcfile->Delete();
  23. }
  24. }
  25. ?>
This control is also available for ASP.NET!

Ajax Uploader for .NET


Before You Begin -- PHP File Upload

PHP File Uploader

Before You Begin

1. Setting temporary file location

PHP File Uploader streams the data into a temporary file while the data is received. By default PHP File Uploader will use the system temporary directory (upload_tmp_dir), which can typically be accessed by all system users. If system temporary directory is not readable or writable by PHP user, you must specify a temporary file location. You should ensure that the PHP user has read/write permission to this specified folder.

You can easily specify the temporary file location using TempDirectory property:

  1. //Register Uploader component to your page
  2. <?php require_once "phpuploader/include_phpuploader.php" ?>
  3. <html>
  4. <body>
  5. <form id="form1" method="POST">
  6. <?php
  7. // Create Uploader object.
  8. $uploader=new PhpUploader();
  9. // Set a unique name to Uploader
  10. $uploader->Name="myuploader";
  11. // specify the temporary file location using TempDirectory property
  12. $uploader->TempDirectory="/mytempfolder";
  13. // Render Uploader
  14. $uploader->Render();
  15. ?>
  16. </form>
  17. </body>
  18. </html>

2. Setting MaxSizeKB

For security purpose, you should specify the limit for the size of uploaded file through MaxDataSize, in kilobytes. This limit can be used to prevent denial of service attacks that are caused, for example, by users uploading large files to the server. The default is no limit.

You can easily specify the maximum allowed size of the file using MaxSizeKB property:

  1. //Register Uploader component to your page
  2. <?php require_once "phpuploader/include_phpuploader.php" ?>
  3. <html>
  4. <body>
  5. <form id="form1" method="POST">
  6. <?php
  7. // Create Uploader object.
  8. $uploader=new PhpUploader();
  9. // Set a unique name to Uploader
  10. $uploader->Name="myuploader";
  11. // Specify the maximum allowed size of the file using MaxSizeKB property
  12. $uploader->MaxSizeKB=1024000;
  13. // Render Uploader
  14. $uploader->Render();
  15. ?>
  16. </form>
  17. </body>
  18. </html>


Choosing Upload Method

PHP File Uploader

Choosing a method to save the uploaded files

There are three ways to handle file uploading with PHP Uploader. You can choose one based on your application requirements.

Simple Upload

Simple Upload is designed for the simplest usage scenario. It calls the SaveDirectory method of the control which actually performs the upload. It automatically parses the information POSTed by the browser, figures out how many files are being uploaded, and saves them in a specified local directory on the server under their original names. An attachment table is also created.

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <?php
  5. $uploader=new PhpUploader();
  6. $uploader->Name="myuploader";
  7. $uploader->SaveDirectory="/myfolder";
  8. $uploader->Render();
  9. ?>
  10. </body>
  11. </html>

That's all that's needed. Really!

Standard PHP Upload

If your usage scenario is close to the simplest case, described above, but you need a little more control, you can use Standard PHP Upload. It allows the PHP developers to process the uploaded files using PHP code. The page posts back to itself to process the uploaded files.

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->Render();
  9. ?>
  10. </form>
  11. <?php
  12. //Gets the GUID of the file based on uploader name
  13. $fileguid=@$_POST["myuploader"];
  14. if($fileguid)
  15. {
  16. //get the uploaded file based on GUID
  17. $mvcfile=$uploader->GetUploadedFile($fileguid);
  18. if($mvcfile)
  19. {
  20. //Gets the name of the file.
  21. echo($mvcfile->FileName);
  22. //Gets the temp file path.
  23. echo($mvcfile->FilePath);
  24. //Gets the size of the file.
  25. echo($mvcfile->FileSize);
  27. //Copys the uploaded file to a new location.
  28. $mvcfile->CopyTo("/uploads");
  29. //Moves the uploaded file to a new location.
  30. $mvcfile->MoveTo("/uploads");
  31. //Deletes this instance.
  32. $mvcfile->Delete();
  33. }
  34. }
  35. ?>
  36. </body>
  37. </html>

Custom file upload handler

If you need further control over the parsing of the file uploading request, you can write a custom file upload handler. In handler page (UploadUrl) developers can rename the uploaded files, process other logics programmatically.

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <?php
  5. $uploader=new PhpUploader();
  6. $uploader->Name="myuploader";
  7. //Create a new file upload handler
  8. $uploader->UploadUrl="myhandler.php";
  9. $uploader->Render();
  10. ?>
  11. </body>
  12. </html>

The following code shows you how to rename the uploaded files, process other logics programmatically in handler page (UploadUrl).

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <?php
  3. $uploader=new PhpUploader();
  5. $mvcfile=$uploader->GetValidatingFile();
  7. if($mvcfile->FileName=="accord.bmp")
  8. {
  9. $uploader->WriteValidationError("My custom error : Invalid file name. ");
  10. exit(200);
  11. }
  13. //USER CODE:
  15. $targetfilepath= "savefiles/myprefix_" . $mvcfile->FileName;
  16. if( is_file ($targetfilepath) )
  17. unlink($targetfilepath);
  18. $mvcfile->MoveTo( $targetfilepath );
  20. $uploader->WriteValidationOK();
  22. ?>


Uploading Multiple Files

PHP File Uploader allows you to select multiple files and upload multiple files at once.

1. Adding Uploader into PHP page and setting MultipleFilesUpload property to true.
  1. //Step 1: Register Uploader component to your page
  2. <?php require_once "phpuploader/include_phpuploader.php" ?>
  3. <html>
  4. <body>
  5. <form id="form1" method="POST">
  6. <?php
  7. //Step 2: Create Uploader object.
  8. $uploader=new PhpUploader();
  9. //Step 3: Set a unique name to Uploader
  10. $uploader->Name="myuploader";
  11. //Step 4: Enable Multiple Files Upload.
  12. $uploader->MultipleFilesUpload=true;
  13. //Step 5: Render Uploader
  14. $uploader->Render();
  15. ?>
  16. </form>
  17. </body>
  18. </html>
2. Retrieving all uploaded files.
  1. <?php
  2. //Gets the file GUID list based on uploader name
  3. $fileguidlist=@$_POST["myuploader"];
  4. if($fileguidlist)
  5. {
  6. $guidlist=split("/",$fileguidlist);
  7. foreach($guidlist as $fileguid)
  8. {
  10. //get the uploaded file based on GUID
  11. $mvcfile=$uploader->GetUploadedFile($fileguid);
  12. if($mvcfile)
  13. {
  14. //Gets the name of the file.
  15. echo($mvcfile->FileName);
  16. //Gets the temp file path.
  17. echo($mvcfile->FilePath);
  18. //Gets the size of the file.
  19. echo($mvcfile->FileSize);
  21. //Copys the uploaded file to a new location.
  22. $mvcfile->CopyTo("/uploads");
  23. //Moves the uploaded file to a new location.
  24. $mvcfile->MoveTo("/uploads");
  25. //Deletes this instance.
  26. $mvcfile->Delete();
  27. }
  28. }
  29. }
  30. ?>
This control is also available for ASP.NET!

Ajax Uploader for .NET


Deploying License File

Deploying PHP File Uploader License File

Copy phpuploader.lic to phpuploader\license folder.


Create a custom upload button -- PHP File Upload

PHP File Uploader

Create a custom upload button

There are two simple steps to create a custom upload button:

  1. Create a HTML button or image button which will be used as custom upload button.
  2. Use the InsertButtonID property to specify the ID of the control that will be used as the upload button.

Example:

  1. //Step 1: Register Uploader component to your page
  2. <?php require_once "phpuploader/include_phpuploader.php" ?>
  3. <html>
  4. <body>
  5. <form id="form1" method="POST">
  6. <?php
  7. //Step 2: Create Uploader object.
  8. $uploader=new PhpUploader();
  9. //Step 3: Set a unique name to Uploader
  10. $uploader->Name="myuploader";
  11. //Step 4: Specify ID of the control that will be used as upload button.
  12. $uploader->InsertButtonID="uploadbutton";
  13. //Step 5: Render Uploader
  14. $uploader->Render();
  15. ?>
  16. <img id="uploadbutton" alt="Upload File" src="sampleimages/upload.png" />
  17. </form>
  18. </body>
  19. </html>


Create a custom cancel button -- PHP File Upload

PHP File Uploader

Create a custom cancel button

There are two simple steps to create a custom cancel button:

  1. Create a HTML button or image button which will be used as custom cancel button.
  2. Use the CancelButtonID property to specify the ID of the control that will be used as the cancel button.

Example:

  1. //Step 1: Register Uploader component to your page
  2. <?php require_once "phpuploader/include_phpuploader.php" ?>
  3. <html>
  4. <body>
  5. <form id="form1" method="POST">
  6. <?php
  7. //Step 2: Create Uploader object.
  8. $uploader=new PhpUploader();
  9. //Step 3: Set a unique name to Uploader
  10. $uploader->Name="myuploader";
  11. //Step 4: Specify ID of the control that will be used as cancel button.
  12. $uploader->CancelButtonID="cancelbutton";
  13. //Step 5: Render Uploader
  14. $uploader->Render();
  15. ?>
  16. <img id="uploadercancelbutton" style='display:none;' alt="Cancel" src="sampleimages/cancel_button.gif" />
  17. </form>
  18. </body>
  19. </html>


Create a custom progress bar panel -- PHP File Upload

PHP File Uploader

Create a custom progress bar panel

There are 4 simple steps to create a custom progress bar panel:

  1. Create a panel control which will be used as custom progress bar panel.
  2. Create a label control inside panel control. This label control will be used as custom progress text label.
  3. Use the ProgressCtrlID property to specify the ID of panel control.
  4. Use the ProgressTextID property to specify the ID of progress text label.

Example:

  1. //Step 1: Register Uploader component to your page
  2. <?php require_once "phpuploader/include_phpuploader.php" ?>
  3. <html>
  4. <body>
  5. <form id="form1" method="POST">
  6. <?php
  7. //Step 2: Create Uploader object.
  8. $uploader=new PhpUploader();
  9. //Step 3: Set a unique name to Uploader
  10. $uploader->Name="myuploader";
  11. //Step 4: Specify the ID of the control that will be used as progress bar panel.
  12. $uploader->ProgressCtrlID="uploaderprogresspanel";
  13. //Step 4: Specify the ID of the control that will be used as progress text label.
  14. $uploader->ProgressTextID="uploaderprogresstext";
  15. //Step 5: Render Uploader
  16. $uploader->Render();
  17. ?>
  18. <div id="uploaderprogresspanel" style='display:none;background-color:orange;border:dashed 2px gray;padding:4px;' BorderColor="Orange" BorderStyle="dashed">
  19. <span id="uploaderprogresstext" style='color:firebrick'></span>
  20. </div>
  21. </form>
  22. </body>
  23. </html>


Create a custom progress template -- PHP File Upload

PHP File Uploader

Create a custom progress template

You can use the ProgressTextTemplate property to create a custom progress template. The default value of this property is:
Uploading %F%. %SEND% of %SIZE% at %KBPS%; %T% seconds remaining.

The following table lists the variables to use when creating a progress template:

Variables | Description
%P% | Total Progress Percent
%T% | Estimated Time Remaining(seconds)
%F% | Current File Name
%SEND% | Uploaded File Size.
%SIZE% | Total File Size
%KBPS% | Current Upload Speed (KB/sec)
%BPS% | Current Upload Speed (B/sec)
&#13;&#10; | Insert a Line Break

Example:

%F%.. %P% %SEND%/%SIZE% , %KBPS% , %T% seconds left


JavaScript API -- PHP File Upload

PHP File Uploader

Extending PHP File Uploader with JavaScript API

The goal of this section is to help you to gain comfort working with PHP File Uploader's JavaScript APIs.

1. Global Event Handlers

With the following global event handlers you can have multiple PHP File Uploader instances on the page where you can attach the same event handler to run the same code.

  • For most functions, returning false would cancel the default action.
  • Using 'this' you can get the uploader object.

Events | Description
CuteWebUI_AjaxUploader_OnInitialize | Fires when an PHP File Uploader is fully initialized.
CuteWebUI_AjaxUploader_OnStart | Fires when an upload of a specific file has started.
CuteWebUI_AjaxUploader_OnStop | Fires when upload is stopped and not do postback.
CuteWebUI_AjaxUploader_OnPostback | Fires before the page do PostBack to server side and fire the FileUploaded event.
CuteWebUI_AjaxUploader_OnBrowse | Fires when the upload button is clicked.
CuteWebUI_AjaxUploader_OnSelect | Fires when files are selected.
CuteWebUI_AjaxUploader_OnProgress | Fires when new information about the upload progress for a specific file is available.
CuteWebUI_AjaxUploader_OnQueueUI | Fires when the upload queue table is available.

Example:

//Fires when an PHP File Uploader is fully initialized

function CuteWebUI_AjaxUploader_OnInitialize()

{

var hidden=this;

//warning , using the internalobject is not recommend .

//if you use it, you need test the uploader again for each new version.

var arr=[];

for(var p in hidden.internalobject)

{

arr.push(p);

}

alert("internal object member list : "+arr);

}

//Fires when an upload of a specific file has started

function CuteWebUI_AjaxUploader_OnStart()

{

var hidden=this;

hidden.internalobject.insertBtn.style.display='none'

}

//Fires when upload is stopped and not do postback

function CuteWebUI_AjaxUploader_OnStop()

{

var hidden=this;

hidden.internalobject.insertBtn.style.display=''

}

//Fires before the page do PostBack to server side and fire the FileUploaded event.

function CuteWebUI_AjaxUploader_OnPostback()

{

var hidden=this;

hidden.internalobject.insertBtn.style.display=''

//thie files are prepaired

//return false to cancel it..

}

//Fires when the upload button is clicked.

function CuteWebUI_AjaxUploader_OnBrowse()

{

//return false to cancel it..

}

//Fires when files are selected.

function CuteWebUI_AjaxUploader_OnSelect(files)

{

//change the files array would take no effect.

var name=files[0].FileName;

var size=files[0].FileSize // (or -1)

//return false to cancel it..

}

//Fires when new information about the upload progress for a specific file is available.

function CuteWebUI_AjaxUploader_OnProgress(enable,filename,begintime,uploadedsize,totalsize)

{

var hidden=this;

if(enable)

{

if(totalsize)

{

document.title=filename+" - "+Math.floor(100*uploadedsize/totalsize)+'%'

}

else

{

}

}

else

{

}

return false; //hide the default UI.

}

//Fires when the upload queue table is available.

function CuteWebUI_AjaxUploader_OnQueueUI(list)

{

var name=list[0].FileName

var size=list[0].FileSize // (or -1)

var stat=list[0].Status // Finish|Error|Upload|Queue

var func=list[0].Cancel;

//display the

//return false to hide the default queue table!

}

2. Instance Event Handler

With the following instance event handlers you can attach event handlers directly to an instance of PHP File Uploader by setting obj.handlexxxxx (lower case).

  • For most functions, returning false would cancel the default action.
  • Using 'this' you can get the uploader object.

Events | Description
handleinitialize | Fires when an PHP File Uploader is fully initialized.
handlestart | Fires when an upload of a specific file has started.
handlestop | Fires when upload is stopped and not do postback.
handlepostback | Fires before the page do PostBack to server side and fire the FileUploaded event.
handlebrowse | Fires when the upload button is clicked.
handleselect | Fires when files are selected.
handleprogress | Fires when new information about the upload progress for a specific file is available.
handlequeueui | Fires when the upload queue table is available.

Example:

var hidden=document.getElementById('myuploader')

hidden.handlebrowse=function()

{

var checkbox=document.getElementById("agreecheckbox");

if(!checkbox.checked)

{

alert("you must agree the contract")

return false;

}

}


Uploader Class

PHP File Uploader is an easy to use, hi-performance File Upload Control which allows you to upload files to web server without refreshing the page. It allows you select and upload multiple files and cancel running uploads, add new files during uploading.

The look and feel of file upload controls can be customized to seamlessly blend into your website design.

Remarks

PHP File Uploader supports all Internet Explorer versions from 5.5 up on Windows, Firefox 1.0+, Mozilla 1.3+, Netscape 7+, Opera 9.x and Safari (1.3+). This includes Macintosh and Linux. If you attempt to use PHP File Uploader using a browser that is not supported Cute Editor for PHP will render as a regular PHP upload control.

Example

  1. //Step 1: Register Uploader component to your page
  2. <?php require_once "phpuploader/include_phpuploader.php" ?>
  3. <html>
  4. <body>
  5. <form id="form1" method="POST">
  6. <?php
  7. //Step 2: Create Uploader object.
  8. $uploader=new PhpUploader();
  9. //Step 3: Set a unique name to Uploader
  10. $uploader->Name="myuploader";
  11. //Step 4: Render Uploader
  12. $uploader->Render();
  13. ?>
  14. </form>
  15. </body>
  16. </html>


AllowedFileExtensions Property

Gets or sets the allowed file extensions for uploading.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->AllowedFileExtensions="jpeg,jpg,gif,png,zip";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ButtonOnClickScript Property

PHP File Uploader Class Reference

Uploader.ButtonOnClickScript Property

JavaScript code that be executed when the browse button be clicked.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->ButtonOnClickScript="myalert()";
  9. $uploader->Render();
  10. ?>
  11. <script>
  12. function myalert()
  13. {
  14. alert("Hello World");
  15. }
  16. </script>
  17. </form>
  18. </body>
  19. </html>


CancelAllMsg Property

PHP File Uploader Class Reference

Uploader.CancelAllMsg Property

Gets or sets the "Cancel all Uploads" message.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->CancelAllMsg="Cancel all Uploads";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


CancelButtonID Property

PHP File Uploader Class Reference

Uploader.CancelButtonID Property

It allows the developers specify a server control to use as the cancel button of PHP File Uploader.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->CancelButtonID="uploadercancelbutton";
  9. $uploader->Render();
  10. ?>
  11. <img id="uploadercancelbutton" style='display:none;' alt="Cancel" src="sampleimages/cancel_button.gif" />
  12. </form>
  13. </body>
  14. </html>


CancelUploadMsg Property

PHP File Uploader Class Reference

Uploader.CancelUploadMsg Property

Gets or sets the "Cancel upload" message.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->CancelUploadMsg="Cancel Uploads";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


DialogFilter Property

PHP File Uploader Class Reference

Uploader.DialogFilter Property

Gets or sets the current file name filter string, which determines the choices that appear in the file browser dialog box. Please note that only ValidateOption.AllowedFileExtensions property determine the allowed file extensions for uploading.

Remarks

For each filtering option, the filter string contains a description of the filter, followed by the vertical bar (|) and the filter pattern. The strings for different filtering options are separated by the vertical bar.

The following is an example of a filter string:

Text files (*.txt)|*.txt|All files (*.*)|*.*

You can add several filter patterns to a filter by separating the file types with semicolons, for example:

Image Files(*.BMP;*.JPG;*.GIF)|*.BMP;*.JPG;*.GIF|All files (*.*)|*.*

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->DialogFilter="Images (jpg/gif/png)|*.jpg;*.gif;*.png|All files (*.*)|*.*";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


FileTooLargeMsg Property

PHP File Uploader Class Reference

Uploader.FileTooLargeMsg Property

Gets or sets the "File too large" message.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->FileTooLargeMsg="{0} cannot be uploaded!\n\nFile size ({1}) is too large. The maximum file size allowed is set to: {2}.";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


FileTypeNotSupportMsg Property

PHP File Uploader Class Reference

Uploader.FileTypeNotSupportMsg Property

Gets or sets the "file type not support" message.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->FileTypeNotSupportMsg="This file extension is not allowed! File extensions allowed: '{0}'";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


FlashWarningImage Property

PHP File Uploader Class Reference

Uploader.FlashWarningImage Property

Gets or sets the FlashWarning Image.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->FlashWarningImage="Flash10Alert.gif";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


InputboxCSSText Property

PHP File Uploader Class Reference

Uploader.InputboxCSSText Property

Sets or retrieves the appearance of the file input control.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->InputboxCSSText="font-size: 12px;";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


InsertButtonID Property

PHP File Uploader Class Reference

Uploader.InsertButtonID Property

It allows the developers specify a server control to use as the insert button of PHP File Uploader.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->InsertButtonID="uploaderbutton";
  9. $uploader->Render();
  10. ?>
  11. <img id="uploaderbutton" alt="Upload" src="sampleimages/uploaderbutton.gif" />
  12. </form>
  13. </body>
  14. </html>


InsertText Property

PHP File Uploader Class Reference

Uploader.InsertText Property

Gets or sets the insert text.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->InsertText="Upload files";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ManualStartUpload Property

PHP File Uploader Class Reference

Uploader.ManualStartUpload Property

Gets or sets a boolean indicating whether Uploader automatically starts uploading as soon as a user selects a file.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <head>
  4. <script type="text/javascript">
  5. function doStart()
  6. {
  7. var uploadobj = document.getElementById('myuploader');
  8. if (uploadobj.getqueuecount() > 0)
  9. {
  10. uploadobj.startupload();
  11. }
  12. else
  13. {
  14. alert("Please browse files for upload");
  15. }
  16. }
  17. </script>
  18. </head>
  19. <body>
  20. <form id="form1" method="POST">
  21. <?php
  22. $uploader=new PhpUploader();
  23. $uploader->Name="myuploader";
  24. $uploader->ManualStartUpload=true;
  25. $uploader->Render();
  26. ?>
  27. <button id="submitbutton" onclick="doStart();return false;">Start Uploading Files</button>
  28. </form>
  29. </body>
  30. </html>


MaxFilesLimit Property

PHP File Uploader Class Reference

Uploader.MaxFilesLimit Property

Gets or sets the maximum number of files that can be uploaded.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->MaxFilesLimit=10;
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


MaxFilesLimitMsg Property

PHP File Uploader Class Reference

Uploader.MaxFilesLimitMsg Property

Gets or sets the "maximum number of files" message.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->MaxFilesLimitMsg="The maximum number of files allowed to be uploaded is set to {0}.";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


MaxSizeKB Property

PHP File Uploader Class Reference

Uploader.MaxSizeKB Property

Gets or sets the maximum allowed size of the file, in KB.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->MaxSizeKB=1024;
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


MultipleFilesUpload Property

PHP File Uploader Class Reference

Uploader.MultipleFilesUpload Property

If true, the users are able to select multiple files in the file browser dialog then upload them at once.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->MultipleFilesUpload=true;
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


NumFilesShowCancelAll Property

PHP File Uploader Class Reference

Uploader.NumFilesShowCancelAll Property

Specifies the number of files when the CancelAll button appears.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->NumFilesShowCancelAll=2;
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ProgressBarBackgroundImage Property

PHP File Uploader Class Reference

Uploader.ProgressBarBackgroundImage Property

Gets or sets the background image for the ProgressBar control.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->ProgressBarBackgroundImage="/images/back.gif";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ProgressBarBorderStyle Property

PHP File Uploader Class Reference

Uploader.ProgressBarBorderStyle Property

Specifies the border style for the ProgressBar control.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->ProgressBarBorderStyle="border:1px solid #444444;";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ProgressBarHeight Property

PHP File Uploader Class Reference

Uploader.ProgressBarHeight Property

The height of the Progress bar. Default is 15.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->ProgressBarHeight=20;
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ProgressBarStyle Property

PHP File Uploader Class Reference

Uploader.ProgressBarStyle Property

Specifies the style that a ProgressBar uses to indicate the progress of an operation.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->ProgressBarStyle="Blocks";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ProgressCtrlID Property

PHP File Uploader Class Reference

Uploader.ProgressCtrlID Property

It allows the developers specify a server control to use as the progress control of PHP File Uploader.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. //Specify the ID of the control that will be used as progress bar panel.
  9. $uploader->ProgressCtrlID="uploaderprogresspanel";
  10. //Specify the ID of the control that will be used as progress text label.
  11. $uploader->ProgressTextID="uploaderprogresstext";
  12. $uploader->Render();
  13. ?>
  14. <div id="uploaderprogresspanel" style='display:none;background-color:orange;border:dashed 2px gray;padding:4px;' BorderColor="Orange" BorderStyle="dashed">
  15. <span id="uploaderprogresstext" style='color:firebrick'></span>
  16. </div>
  17. </form>
  18. </body>
  19. </html>


ProgressInfoStyle Property

PHP File Uploader Class Reference

Uploader.ProgressInfoStyle Property

The style to be applied to the progress information.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->ProgressInfoStyle="padding-left:3px;font:normal 12px Tahoma;";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ProgressPanelWidth Property

PHP File Uploader Class Reference

Uploader.ProgressPanelWidth Property

The width of the Progress Panel. Default is 500.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->ProgressPanelWidth=400;
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ProgressPicture Property

PHP File Uploader Class Reference

Uploader.ProgressPicture Property

Gets or sets a progress fill picture for the ProgressBar control.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->ProgressPicture="/images/ProgressPicture.gif";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ProgressTextID Property

PHP File Uploader Class Reference

Uploader.ProgressTextID Property

It allows the developers specify a server control to show the progress text of PHP File Uploader.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. //Specify the ID of the control that will be used as progress bar panel.
  9. $uploader->ProgressCtrlID="uploaderprogresspanel";
  10. //Specify the ID of the control that will be used as progress text label.
  11. $uploader->ProgressTextID="uploaderprogresstext";
  12. $uploader->Render();
  13. ?>
  14. <div id="uploaderprogresspanel" style='display:none;background-color:orange;border:dashed 2px gray;padding:4px;' BorderColor="Orange" BorderStyle="dashed">
  15. <span id="uploaderprogresstext" style='color:firebrick'></span>
  16. </div>
  17. </form>
  18. </body>
  19. </html>


ProgressTextTemplate Property

PHP File Uploader Class Reference

Uploader.ProgressTextTemplate Property

Gets or sets the progress text template. %P% = percent,%T% = seconds remain,%F% = filename. %SEND% = uploaded size , %SIZE% = file size , %KBPS% means KB/s , %KBPS% = B/s For example : %F%.. %P% %SEND%/%SIZE% , %KBPS% , %T% seconds left.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->ProgressTextTemplate="%F%.. %P% %SEND%/%SIZE% , %KBPS% , %T% seconds left.";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


SaveDirectory Property

PHP File Uploader Class Reference

Uploader.SaveDirectory Property

Specifies the directory on the server to save the uploaded file to.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->SaveDirectory="/myfolder";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ShowFrameBrowseButton Property

PHP File Uploader Class Reference

Uploader.ShowFrameBrowseButton Property

Gets or sets a boolean indicating whether Uploader should render a browse button for FireFox/Opera in Iframe Mode.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->ShowFrameBrowseButton=true;
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ShowProgressBar Property

PHP File Uploader Class Reference

Uploader.ShowProgressBar Property

Gets or sets a value indicating whether the progress bar is displayed. The UploadModule must be installed to use this feature.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->ShowProgressBar=true;
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


ShowProgressInfo Property

PHP File Uploader Class Reference

Uploader.ShowProgressInfo Property

Gets or sets a value indicating whether the progress information is displayed when uploading. The UploadModule must be installed to use this feature.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->ShowProgressInfo=true;
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


TempDirectory Property

PHP File Uploader Class Reference

Uploader.TempDirectory Property

Specifies where AjaxUploader should put the temporary files.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->TempDirectory="/myTempDirectory";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


UploadCursor Property

PHP File Uploader Class Reference

Uploader.UploadCursor Property

Specifies the upload button built in cursor types.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->UploadCursor ="Hand";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>

Members

Member Name | Description
Auto | Default. The browser sets a cursor.
Arrow | A standard arrow cursor.
Hand | A hand cursor.


UploadingMsg Property

PHP File Uploader Class Reference

Uploader.UploadingMsg Property

Gets or sets the "Uploading.." message.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->UploadingMsg="Uploading..";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


UploadProcessingMsg Property

PHP File Uploader Class Reference

Uploader.UploadProcessingMsg Property

Gets or sets the "upload is processing" message.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->UploadProcessingMsg="Processing....";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


UploadType Property

PHP File Uploader Class Reference

Uploader.UploadType Property

The global type of upload method to use.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->UploadType="Iframe";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>

Members

Member Name | Description
Auto | Determines browser capabilities and chooses the most appropriate method to upload.
Flash | Uses an enhanced file dialog facilitated by a Flash object.
Silverlight | Uses an enhanced file dialog facilitated by a Silverlight object.
IFrame | Uses a standard IFrame technique to provide upload functionality without requiring the Flash plugin.


WindowsDialogLimitMsg Property

PHP File Uploader Class Reference

Uploader.WindowsDialogLimitMsg Property

Gets or sets the message for windows file browse dialog 32K file name length limitation.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->WindowsDialogLimitMsg="Unable to select so many files at once.";
  9. $uploader->Render();
  10. ?>
  11. </form>
  12. </body>
  13. </html>


Uploader.Render Method

Render the Uploader on the client.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->Render();
  9. ?>
  10. </form>
  11. </body>
  12. </html>


Uploader.GetString Method

This function returns what the Render function used to write to the response buffer as a string.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. echo $uploader->GetString();
  9. ?>
  10. </form>
  11. </body>
  12. </html>


PhpUploadFile Class

Provides data for the uploaded files.


PhpUploadFile Properties

PHP File Uploader Class Reference

PhpUploadFile

The properties of the PhpUploadFile class are listed below.

Public Instance Properties
FileGuid | Gets the GUID of the file.
FileName | Gets the name of the file.
FileSize | Gets the size of the file.


FileGuid Property

PHP File Uploader Class Reference

PhpUploadFile.FileGuid Property

Gets the GUID of the file.

Example Code

  1. <?php
  2. //Gets the GUID of the file based on uploader name
  3. $fileguid=@$_POST["myuploader"];
  4. if($fileguid)
  5. {
  6. //get the uploaded file based on GUID
  7. $mvcfile=$uploader->GetUploadedFile($fileguid);
  8. if($mvcfile)
  9. {
  10. //Gets the GUID of the file.
  11. echo($mvcfile->FileGuid);
  12. }
  13. }
  14. ?>


FileName Property

PHP File Uploader Class Reference

PhpUploadFile.FileName Property

Gets the name of the file.

  1. <?php
  2. //Gets the GUID of the file based on uploader name
  3. $fileguid=@$_POST["myuploader"];
  4. if($fileguid)
  5. {
  6. //get the uploaded file based on GUID
  7. $mvcfile=$uploader->GetUploadedFile($fileguid);
  8. if($mvcfile)
  9. {
  10. //Gets the name of the file.
  11. echo($mvcfile->FileName);
  12. }
  13. }
  14. ?>


FileSize Property

PHP File Uploader Class Reference

PhpUploadFile.FileSize Property

Gets the size of the file.

  1. <?php
  2. //Gets the GUID of the file based on uploader name
  3. $fileguid=@$_POST["myuploader"];
  4. if($fileguid)
  5. {
  6. //get the uploaded file based on GUID
  7. $mvcfile=$uploader->GetUploadedFile($fileguid);
  8. if($mvcfile)
  9. {
  10. //Gets the size of the file.
  11. echo($mvcfile->FileSize);
  12. }
  13. }
  14. ?>


PhpUploadFile.FilePath Property

Gets the temp file path.

  1. <?php
  2. //Gets the GUID of the file based on uploader name
  3. $fileguid=@$_POST["myuploader"];
  4. if($fileguid)
  5. {
  6. //get the uploaded file based on GUID
  7. $mvcfile=$uploader->GetUploadedFile($fileguid);
  8. if($mvcfile)
  9. {
  10. //Gets the name of the file.
  11. echo($mvcfile->FileName);
  12. //Gets the temp file path.
  13. echo($mvcfile->FilePath);
  14. //Gets the size of the file.
  15. echo($mvcfile->FileSize);
  17. //Copys the uploaded file to a new location.
  18. $mvcfile->CopyTo("/uploads");
  19. //Moves the uploaded file to a new location.
  20. $mvcfile->MoveTo("/uploads");
  21. //Deletes this instance.
  22. $mvcfile->Delete();
  23. }
  24. }
  25. ?>

Send comments on this topic.


PhpUploadFile Methods

PHP File Uploader Class Reference

UploaderEventArgs Methods

The methods of the PhpUploadFile class are listed below. For a complete list of PhpUploadFile class members, see the PhpUploadFile Members topic.

Public Instance Methods
CopyTo | Copys the uploaded file to a new location.
Delete | Deletes this instance.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetTempFilePath | Gets the temp file path.
GetType (inherited from Object) |
MoveTo | Moves the uploaded file to a new location.
OpenStream | Opens the uploaded file's data stream.
Persist | Persists this instance.
ToString (inherited from Object) |
Protected Instance Methods
Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
See Also

PhpUploadFile Class | CuteWebUI Namespace


PhpUploadFile.CopyTo Method

Copys the uploaded file to a new location.

  1. <?php
  2. //Gets the GUID of the file based on uploader name
  3. $fileguid=@$_POST["myuploader"];
  4. if($fileguid)
  5. {
  6. //get the uploaded file based on GUID
  7. $mvcfile=$uploader->GetUploadedFile($fileguid);
  8. if($mvcfile)
  9. //Copys the uploaded file to a new location.
  10. $mvcfile->CopyTo("/uploads");
  11. }
  12. }
  13. ?>


PhpUploadFile.Delete Method

Deletes this instance.

  1. <?php
  2. //Gets the GUID of the file based on uploader name
  3. $fileguid=@$_POST["myuploader"];
  4. if($fileguid)
  5. {
  6. //get the uploaded file based on GUID
  7. $mvcfile=$uploader->GetUploadedFile($fileguid);
  8. if($mvcfile)
  9. {
  10. //Deletes this instance.
  11. $mvcfile->Delete();
  12. }
  13. }
  14. ?>


PhpUploadFile.MoveTo Method

Moves the uploaded file to a new location.

  1. <?php
  2. //Gets the GUID of the file based on uploader name
  3. $fileguid=@$_POST["myuploader"];
  4. if($fileguid)
  5. {
  6. //get the uploaded file based on GUID
  7. $mvcfile=$uploader->GetUploadedFile($fileguid);
  8. if($mvcfile)
  9. {
  10. //Moves the uploaded file to a new location.
  11. $mvcfile->MoveTo("/uploads");
  12. }
  13. }
  14. ?>


CuteWebUI

PHP File Uploader Class Reference

CuteWebUI Namespace

CuteWebUI is a collection of classes that allow you to create Web server controls on an ASP.NET Web page.

Namespace hierarchy

Classes

Class | Description
AttachmentItem | This class represents an Attachment Item.
AttachmentItemCollection | This class represents/maintains a collection of Attachment items.
AttachmentItemEventArgs | Event parameters used for events (AttachmentCheckChanged,AttachmentCreated,AttachmentDataBound,AttachmentAdded) that take an Item as one of its arguments.
PersistedFile | This class represents a Single File object.
PersistedFileEventArgs | Provides data for the FileChanged events.
UploadAttachments | This class allows you upload multiple files with a single element. The uploaded file will be added to the list of attachments. Just the way Gmail does for email attachment.
Uploader | This class represents an enhanced control for uploading files to the server.
UploaderBase | The base class defines the properties, methods, and events that are shared by Uploader, UploadPersistedFile and UploadAttachments.
PhpUploadFile | Provides data for the FileValidating and FileUploaded(After Upload) events.
UploaderLicenseException |
UploaderLicenseProvider | UploaderLicenseProvider
UploaderProvider | This abstract class represents a Uploader Provider object.
UploaderValidateOption | A helper class which can be used to hold validation information, used by the PHP File Uploader.
UploadFileBase | Represents an UploadFileBase object.
UploadModule | This class represents an Upload Module object.
UploadPersistedFile | This class represents an enhanced control for uploading files to the server. The object can persist across postbacks.

Interfaces

Interface | Description
IAttachmentProvider | Represents an interface for an Attachment Provider.

Delegates

Delegate | Description
AttachmentItemEventHandler | Represents the method that will handle Attachment control events.
PersistedFileEventHandler | Represents the method that will handle Uploader control events.
UploaderEventHandler | Represents the method that will handle Uploader control events.

Enumerations

Enumeration | Description
AttachmentItemBehavior |
AttachmentItemTemplatePosition | Specifies the Attachment Item Template Position.
EnumUploaderLicense |
ProgressBarType | Specifies the style that a ProgressBar uses to indicate the progress of an operation.
UploaderAdvancedOption | This enumeration is used by Uploader.SetAdvancedOption.
UploadType | The global type of upload method to use.


AttachmentItem Class

This class represents an Attachment Item.

For a list of all members of this type, see AttachmentItem Members.

System.Object
System.Web.UI.Control
CuteWebUI.AttachmentItem

[Visual Basic]
Public Class AttachmentItem
Inherits Control
Implements INamingContainer, IPostBackEventHandler
[C#]
public class AttachmentItem : Control, INamingContainer, IPostBackEventHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

AttachmentItem Members | CuteWebUI Namespace


AttachmentItem.ChangeToCustom Method

Changes this instance to a custom item.

[Visual Basic]
Public Sub ChangeToCustom( _
ByVal newguid As Guid _
)
[C#]
public void ChangeToCustom(
Guid newguid
);
Parameters
newguid
The newguid.
See Also

AttachmentItem Class | CuteWebUI Namespace


Checked Property

PHP File Uploader Class Reference

AttachmentItem.Checked Property

Gets or sets a value indicating whether this AttachmentItem is checked.

[Visual Basic]
Public Property Checked As Boolean
[C#]
public bool Checked {get; set;}

Property Value

true if checked; otherwise, false.

See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItem.CopyTo Method

Copys the uploaded file to a new location.

[Visual Basic]
Public Sub CopyTo( _
ByVal newpath As String _
)
[C#]
public void CopyTo(
string newpath
);
Parameters
newpath
The location where he uploaded file is saved.
See Also

AttachmentItem Class | CuteWebUI Namespace


DataItem Property

PHP File Uploader Class Reference

AttachmentItem.DataItem Property

Gets the data item.

[Visual Basic]
Public ReadOnly Property DataItem As AttachmentItem
[C#]
public AttachmentItem DataItem {get;}

Property Value

The data item.

See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItem.Delete Method

Deletes this instance.

[Visual Basic]
Public Sub Delete()
[C#]
public void Delete();
See Also

AttachmentItem Class | CuteWebUI Namespace


FileGuid Property

PHP File Uploader Class Reference

AttachmentItem.FileGuid Property

Gets the file GUID.

[Visual Basic]
Public ReadOnly Property FileGuid As Guid
[C#]
public System.Guid FileGuid {get;}

Property Value

The file GUID.

See Also

AttachmentItem Class | CuteWebUI Namespace


FileName Property

PHP File Uploader Class Reference

AttachmentItem.FileName Property

Gets the name of the file.

[Visual Basic]
Public ReadOnly Property FileName As String
[C#]
public string FileName {get;}

Property Value

The name of the file.

See Also

AttachmentItem Class | CuteWebUI Namespace


FileSize Property

PHP File Uploader Class Reference

AttachmentItem.FileSize Property

Gets the size of the file.

[Visual Basic]
Public ReadOnly Property FileSize As Integer
[C#]
public int FileSize {get;}

Property Value

The size of the file.

See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItem.GetTempFilePath Method

Gets the temp file path.

[Visual Basic]
Public Function GetTempFilePath() As String
[C#]
public string GetTempFilePath();
Return Value

See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItem.HideAndUncheck Method

Same as the 'remove' button , just hide and uncheck this item.

[Visual Basic]
Public Sub HideAndUncheck()
[C#]
public void HideAndUncheck();
See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItem.InitProperties Method

[Visual Basic]
Overridable Protected Function InitProperties() As Boolean
[C#]
protected virtual bool InitProperties();
See Also

AttachmentItem Class | CuteWebUI Namespace


IsCustom Property

PHP File Uploader Class Reference

AttachmentItem.IsCustom Property

Gets a value indicating whether this instance is custom.

[Visual Basic]
Public ReadOnly Property IsCustom As Boolean
[C#]
public bool IsCustom {get;}

Property Value

true if this instance is custom; otherwise, false.

See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItem.LoadViewState Method

[Visual Basic]
Overrides Protected Sub LoadViewState( _
ByVal savedState As Object _
)
[C#]
protected override void LoadViewState(
object savedState
);
See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItem.MoveTo Method

Moves the uploaded file to a new location.

[Visual Basic]
Public Sub MoveTo( _
ByVal newpath As String _
)
[C#]
public void MoveTo(
string newpath
);
Parameters
newpath
The location where he uploaded file is saved.
See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItem.OnDataBinding Method

Raises the DataBinding event.

[Visual Basic]
Overrides Protected Sub OnDataBinding( _
ByVal e As EventArgs _
)
[C#]
protected override void OnDataBinding(
EventArgs e
);
Parameters
e
An EventArgs object that contains the event data.
See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItem.OpenStream Method

[Visual Basic]
Public Function OpenStream() As Stream
[C#]
public Stream OpenStream();
See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItem.Remove Method

Removes this instance from collection but do not delete it.

[Visual Basic]
Public Sub Remove()
[C#]
public void Remove();
See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItem.Render Method

[Visual Basic]
Overrides Protected Sub Render( _
ByVal writer As HtmlTextWriter _
)
[C#]
protected override void Render(
HtmlTextWriter writer
);
See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItem.SaveViewState Method

[Visual Basic]
Overrides Protected Function SaveViewState() As Object
[C#]
protected override object SaveViewState();
See Also

AttachmentItem Class | CuteWebUI Namespace


ShouldSave Property

PHP File Uploader Class Reference

AttachmentItem.ShouldSave Property

Gets a value indicating whether the item is checked and not a custom item.

[Visual Basic]
Public ReadOnly Property ShouldSave As Boolean
[C#]
public bool ShouldSave {get;}

Property Value

true if [should save]; otherwise, false.

See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItemBehavior Enumeration

[Visual Basic]
Public Enum AttachmentItemBehavior
[C#]
public enum AttachmentItemBehavior
Members
Member Name | Description
None |
HideAndUncheck |
Delete |
AutoRemove | HideAndUncheck for custom items, Delete for uploaded items.
Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

CuteWebUI Namespace


AttachmentItemCollection Class

This class represents/maintains a collection of Attachment items.

For a list of all members of this type, see AttachmentItemCollection Members.

System.Object
CuteWebUI.AttachmentItemCollection

[Visual Basic]
Public Class AttachmentItemCollection
Implements ICollection, IEnumerable
[C#]
public class AttachmentItemCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

AttachmentItemCollection Members | CuteWebUI Namespace


AttachmentItemCollection.Add Method

Adds the specified filesize.

[Visual Basic]
Public Sub Add( _
ByVal filesize As Integer, _
ByVal filename As String, _
ByVal stream As Stream _
)
[C#]
public void Add(
int filesize,
string filename,
Stream stream
);
Parameters
filesize
The filesize.
filename
The filename.
stream
The stream.
See Also

AttachmentItemCollection Class | CuteWebUI Namespace


AttachmentItemCollection.CopyTo Method

Copies the elements of the ICollection to an Array, starting at a particular Array index.

[Visual Basic]
NotOverridable Public Sub CopyTo( _
ByVal array As Array, _
ByVal index As Integer _
) _
Implements ICollection.CopyTo
[C#]
public void CopyTo(
Array array,
int index
);
Parameters
array
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.
Implements

ICollection.CopyTo

Exceptions
Exception Type | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | index is less than zero.
ArgumentException | array is multidimensional.-or- index is equal to or greater than the length of array.-or- The number of elements in the source ICollection is greater than the available space from index to the end of the destination array.
InvalidCastException | The type of the source ICollection cannot be cast automatically to the type of the destination array.
See Also

AttachmentItemCollection Class | CuteWebUI Namespace


Count Property

PHP File Uploader Class Reference

AttachmentItemCollection.Count Property

Gets the number of elements contained in the ICollection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Property Value

Implements

ICollection.Count

See Also

AttachmentItemCollection Class | CuteWebUI Namespace


AttachmentItemCollection.GetEnumerator Method

Returns an enumerator that iterates through a collection.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();
Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable.GetEnumerator

See Also

AttachmentItemCollection Class | CuteWebUI Namespace


IsSynchronized Property

PHP File Uploader Class Reference

AttachmentItemCollection.IsSynchronized Property

Gets a value indicating whether access to the ICollection is synchronized (thread safe).

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public bool IsSynchronized {get;}

Property Value

Implements

ICollection.IsSynchronized

See Also

AttachmentItemCollection Class | CuteWebUI Namespace


Item Property

PHP File Uploader Class Reference

AttachmentItemCollection.Item Property

Gets the AttachmentItem at the specified index.

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As AttachmentItem
[C#]
public AttachmentItem this[
int index
] {get;}

Property Value

See Also

AttachmentItemCollection Class | CuteWebUI Namespace


SyncRoot Property

PHP File Uploader Class Reference

AttachmentItemCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the ICollection.

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object _
Implements ICollection.SyncRoot
[C#]
public object SyncRoot {get;}

Property Value

Implements

ICollection.SyncRoot

See Also

AttachmentItemCollection Class | CuteWebUI Namespace


AttachmentItemCollection.ToArray Method

Toes the array.

[Visual Basic]
Public Function ToArray() As AttachmentItem()
[C#]
public AttachmentItem[] ToArray();
Return Value

See Also

AttachmentItemCollection Class | CuteWebUI Namespace


AttachmentItemCollection Members

AttachmentItemCollection overview

Public Instance Properties
Count | Gets the number of elements contained in the ICollection.
IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe).
Item | Gets the AttachmentItem at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the ICollection.
Public Instance Methods
Add | Adds the specified filesize.
CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Equals (inherited from Object) |
GetEnumerator | Returns an enumerator that iterates through a collection.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToArray | Toes the array.
ToString (inherited from Object) |
Protected Instance Methods
Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
See Also

AttachmentItemCollection Class | CuteWebUI Namespace


AttachmentItem Constructor

[Visual Basic]
Protected Friend Sub New( _
ByVal parent As UploadAttachments _
)
[C#]
protected internal AttachmentItem(
UploadAttachments parent
);
See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItemEventArgs Class

Event parameters used for events (AttachmentCheckChanged,AttachmentCreated,AttachmentDataBound,AttachmentAdded) that take an Item as one of its arguments.

For a list of all members of this type, see AttachmentItemEventArgs Members.

System.Object
CuteWebUI.AttachmentItemEventArgs

[Visual Basic]
Public Class AttachmentItemEventArgs
[C#]
public class AttachmentItemEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

This class is used in the Attachment Item events. It provides some usesful information.

Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

AttachmentItemEventArgs Members | CuteWebUI Namespace


Behavior Property

PHP File Uploader Class Reference

AttachmentItemEventArgs.Behavior Property

provide more option for AttachmentRemoveClicked/ActionButtonClicked event.

[Visual Basic]
Public Property Behavior As AttachmentItemBehavior
[C#]
public AttachmentItemBehavior Behavior {get; set;}

See Also

AttachmentItemEventArgs Class | CuteWebUI Namespace


Item Property

PHP File Uploader Class Reference

AttachmentItemEventArgs.Item Property

Gets the item.

[Visual Basic]
Public ReadOnly Property Item As AttachmentItem
[C#]
public AttachmentItem Item {get;}

Property Value

The item.

See Also

AttachmentItemEventArgs Class | CuteWebUI Namespace


AttachmentItemEventArgs Constructor

Initializes a new instance of the AttachmentItemEventArgs class.

[Visual Basic]
Public Sub New( _
ByVal item As AttachmentItem _
)
[C#]
public AttachmentItemEventArgs(
AttachmentItem item
);
Parameters
item
The item.
See Also

AttachmentItemEventArgs Class | CuteWebUI Namespace


AttachmentItemEventArgs Members

AttachmentItemEventArgs overview

Public Instance Constructors
AttachmentItemEventArgs Constructor Initializes a new instance of the AttachmentItemEventArgs class.
Public Instance Properties
Behavior | provide more option for AttachmentRemoveClicked/ActionButtonClicked event.
Item | Gets the item.
Public Instance Methods
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)
Protected Instance Methods
Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
See Also

AttachmentItemEventArgs Class | CuteWebUI Namespace


AttachmentItemEventHandler Delegate

Represents the method that will handle Attachment control events.

[Visual Basic]
Public Delegate Sub AttachmentItemEventHandler( _
ByVal sender As Object, _
ByVal args As AttachmentItemEventArgs _
)
[C#]
public delegate void AttachmentItemEventHandler(
object sender,
AttachmentItemEventArgs args
);
Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

CuteWebUI Namespace


AttachmentItem Members

AttachmentItem overview

Public Instance Properties
BindingContainer (inherited from Control) |
Checked | Gets or sets a value indicating whether this AttachmentItem is checked.
ClientID (inherited from Control) |
Controls (inherited from Control) |
DataItem | Gets the data item.
EnableViewState (inherited from Control) |
FileGuid | Gets the file GUID.
FileName | Gets the name of the file.
FileSize | Gets the size of the file.
ID (inherited from Control) |
IsCustom | Gets a value indicating whether this instance is custom.
NamingContainer (inherited from Control) |
Page (inherited from Control) |
Parent (inherited from Control) |
ShouldSave | Gets a value indicating whether the item is checked and not a custom item.
Site (inherited from Control) |
TemplateSourceDirectory (inherited from Control) |
UniqueID (inherited from Control) |
Visible (inherited from Control) |
Public Instance Methods
ChangeToCustom | Changes this instance to a custom item.
CopyTo | Copys the uploaded file to a new location.
DataBind (inherited from Control) |
Delete | Deletes this instance.
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) | Overloaded.
GetHashCode (inherited from Object) |
GetTempFilePath | Gets the temp file path.
GetType (inherited from Object) |
HasControls (inherited from Control) |
HideAndUncheck | Same as the 'remove' button , just hide and uncheck this item.
MoveTo | Moves the uploaded file to a new location.
OpenStream |
Remove | Removes this instance from collection but do not delete it.
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |
Public Instance Events
DataBinding (inherited from Control)
Disposed (inherited from Control)
Init (inherited from Control)
Load (inherited from Control)
PreRender (inherited from Control)
Unload (inherited from Control)
Protected Instance Properties
ChildControlsCreated (inherited from Control)
Context (inherited from Control)
Events (inherited from Control)
HasChildViewState (inherited from Control)
IsTrackingViewState (inherited from Control)
ViewState (inherited from Control)
ViewStateIgnoresCase (inherited from Control)
Protected Instance Methods
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) | Overloaded.
InitProperties |
IsLiteralContent (inherited from Control) |
LoadViewState |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding | Raises the DataBinding event.
OnInit (inherited from Control) |
OnLoad (inherited from Control) |
OnPreRender (inherited from Control) |
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
Render |
RenderChildren (inherited from Control) |
SaveViewState |
TrackViewState (inherited from Control) |
Protected Internal Instance Constructors
AttachmentItem Constructor
Protected Internal Instance Methods
AddedControl (inherited from Control)
RemovedControl (inherited from Control)
See Also

AttachmentItem Class | CuteWebUI Namespace


AttachmentItemTemplatePosition Enumeration

Specifies the Attachment Item Template Position.

[Visual Basic]
Public Enum AttachmentItemTemplatePosition
[C#]
public enum AttachmentItemTemplatePosition
Members
Member Name | Description
AnotherCell | Another Cell
ReplaceText | Replace Text
BeforeText | Before Text
AfterText | After Text
BeforeCheckBox | Before CheckBox
AfterCheckBox | After CheckBox
Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

CuteWebUI Namespace


EnumUploaderLicense Enumeration

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
Public Enum EnumUploaderLicense
[C#]
public enum EnumUploaderLicense
Members
Member Name | Description | Value
AjaxUploader |  | 0
Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

CuteWebUI Namespace


IAttachmentProvider Interface

Represents an interface for an Attachment Provider.

For a list of all members of this type, see IAttachmentProvider Members.

[Visual Basic]
Public Interface IAttachmentProvider
[C#]
public interface IAttachmentProvider
Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

IAttachmentProvider Members | CuteWebUI Namespace


IAttachmentProvider.CloseQuery Method

[Visual Basic]
Sub CloseQuery( _
ByVal cookie As Object _
)
[C#]
void CloseQuery(
object cookie
);
See Also

IAttachmentProvider Interface | CuteWebUI Namespace


IAttachmentProvider.DeleteFile Method

[Visual Basic]
Sub DeleteFile( _
ByVal guid As Guid, _
ByVal cookie As Object _
)
[C#]
void DeleteFile(
Guid guid,
object cookie
);
See Also

IAttachmentProvider Interface | CuteWebUI Namespace


IAttachmentProvider.FileExists Method

[Visual Basic]
Function FileExists( _
ByVal guid As Guid, _
ByVal cookie As Object _
) As Boolean
[C#]
bool FileExists(
Guid guid,
object cookie
);
See Also

IAttachmentProvider Interface | CuteWebUI Namespace


IAttachmentProvider.GetFileName Method

[Visual Basic]
Function GetFileName( _
ByVal guid As Guid, _
ByVal cookie As Object _
) As String
[C#]
string GetFileName(
Guid guid,
object cookie
);
See Also

IAttachmentProvider Interface | CuteWebUI Namespace


IAttachmentProvider.GetFileSize Method

[Visual Basic]
Function GetFileSize( _
ByVal guid As Guid, _
ByVal cookie As Object _
) As Integer
[C#]
int GetFileSize(
Guid guid,
object cookie
);
See Also

IAttachmentProvider Interface | CuteWebUI Namespace


IAttachmentProvider.HasTempPath Method

[Visual Basic]
Function HasTempPath( _
ByVal guid As Guid, _
ByVal cookie As Object _
) As String
[C#]
string HasTempPath(
Guid guid,
object cookie
);
See Also

IAttachmentProvider Interface | CuteWebUI Namespace


IAttachmentProvider.OpenFileStream Method

[Visual Basic]
Function OpenFileStream( _
ByVal guid As Guid, _
ByVal cookie As Object _
) As Stream
[C#]
Stream OpenFileStream(
Guid guid,
object cookie
);
See Also

IAttachmentProvider Interface | CuteWebUI Namespace


IAttachmentProvider.OpenQuery Method

[Visual Basic]
Function OpenQuery( _
ByVal guid As Guid _
) As Object
[C#]
object OpenQuery(
Guid guid
);
See Also

IAttachmentProvider Interface | CuteWebUI Namespace


IAttachmentProvider Members

IAttachmentProvider overview

Public Instance Methods
CloseQuery
DeleteFile
FileExists
GetFileName
GetFileSize
HasTempPath
OpenFileStream
OpenQuery
See Also

IAttachmentProvider Interface | CuteWebUI Namespace


PersistedFile Class

This class represents a Single File object.

For a list of all members of this type, see PersistedFile Members.

System.Object
CuteWebUI.PersistedFile

[Visual Basic]
Public Class PersistedFile
[C#]
public class PersistedFile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

PersistedFile Members | CuteWebUI Namespace


PersistedFile.CopyTo Method

Copys the uploaded file to a new location.

[Visual Basic]
Public Sub CopyTo( _
ByVal newpath As String _
)
[C#]
public void CopyTo(
string newpath
);
Parameters
newpath
The location where he uploaded file is saved.
See Also

PersistedFile Class | CuteWebUI Namespace


PersistedFile.Delete Method

Deletes this instance.

[Visual Basic]
Public Sub Delete()
[C#]
public void Delete();
See Also

PersistedFile Class | CuteWebUI Namespace


FileGuid Property

PHP File Uploader Class Reference

PersistedFile.FileGuid Property

Gets the GUID of the file.

[Visual Basic]
Public ReadOnly Property FileGuid As Guid
[C#]
public System.Guid FileGuid {get;}

Property Value

The GUID of the file.

See Also

PersistedFile Class | CuteWebUI Namespace


FileName Property

PHP File Uploader Class Reference

PersistedFile.FileName Property

Gets the name of the file.

[Visual Basic]
Public ReadOnly Property FileName As String
[C#]
public string FileName {get;}

Property Value

The name of the file.

See Also

PersistedFile Class | CuteWebUI Namespace


FileSize Property

PHP File Uploader Class Reference

PersistedFile.FileSize Property

Gets the size of the file.

[Visual Basic]
Public ReadOnly Property FileSize As Integer
[C#]
public int FileSize {get;}

Property Value

The size of the file.

See Also

PersistedFile Class | CuteWebUI Namespace


PersistedFile.GetTempFilePath Method

Gets the temp file path.

[Visual Basic]
Public Function GetTempFilePath() As String
[C#]
public string GetTempFilePath();
Return Value

See Also

PersistedFile Class | CuteWebUI Namespace


PersistedFile.MoveTo Method

Moves the uploaded file to a new location.

[Visual Basic]
Public Sub MoveTo( _
ByVal newpath As String _
)
[C#]
public void MoveTo(
string newpath
);
Parameters
newpath
The location where he uploaded file is saved.
See Also

PersistedFile Class | CuteWebUI Namespace


PersistedFile.OpenStream Method

Opens the uploaded file's data stream.

[Visual Basic]
Public Function OpenStream() As Stream
[C#]
public Stream OpenStream();
Return Value

See Also

PersistedFile Class | CuteWebUI Namespace


PersistedFile.Persist Method

Persists this instance.

[Visual Basic]
Public Sub Persist()
[C#]
public void Persist();
See Also

PersistedFile Class | CuteWebUI Namespace


PersistedFileEventArgs Class

Provides data for the FileChanged events.

For a list of all members of this type, see PersistedFileEventArgs Members.

System.Object
CuteWebUI.PhpUploadFile
CuteWebUI.PersistedFileEventArgs

[Visual Basic]
Public Class PersistedFileEventArgs
Inherits PhpUploadFile
[C#]
public class PersistedFileEventArgs : PhpUploadFile

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

PersistedFileEventArgs Members | CuteWebUI Namespace


File Property

PHP File Uploader Class Reference

PersistedFileEventArgs.File Property

Gets the file.

[Visual Basic]
Public ReadOnly Property File As PersistedFile
[C#]
public PersistedFile File {get;}

Property Value

The file.

See Also

PersistedFileEventArgs Class | CuteWebUI Namespace


PersistedFileEventArgs Members

PersistedFileEventArgs overview

Public Instance Properties
File | Gets the file.
FileGuid (inherited from PhpUploadFile) | Gets the GUID of the file.
FileName (inherited from PhpUploadFile) | Gets the name of the file.
FileSize (inherited from PhpUploadFile) | Gets the size of the file.
Public Instance Methods
CopyTo (inherited from PhpUploadFile) | Copys the uploaded file to a new location.
Delete (inherited from PhpUploadFile) | Deletes this instance.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetTempFilePath (inherited from PhpUploadFile) | Gets the temp file path.
GetType (inherited from Object) |
MoveTo (inherited from PhpUploadFile) | Moves the uploaded file to a new location.
OpenStream (inherited from PhpUploadFile) | Opens the uploaded file's data stream.
Persist (inherited from PhpUploadFile) | Persists this instance.
ToString (inherited from Object) |
Protected Instance Methods
Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
See Also

PersistedFileEventArgs Class | CuteWebUI Namespace


PersistedFileEventHandler Delegate

Represents the method that will handle Uploader control events.

[Visual Basic]
Public Delegate Sub PersistedFileEventHandler( _
ByVal sender As Object, _
ByVal args As PersistedFileEventArgs _
)
[C#]
public delegate void PersistedFileEventHandler(
object sender,
PersistedFileEventArgs args
);
Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

CuteWebUI Namespace


PersistedFile Members

PersistedFile overview

Public Instance Properties
FileGuid | Gets the GUID of the file.
FileName | Gets the name of the file.
FileSize | Gets the size of the file.
Public Instance Methods
CopyTo | Copys the uploaded file to a new location.
Delete | Deletes this instance.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetTempFilePath | Gets the temp file path.
GetType (inherited from Object) |
MoveTo | Moves the uploaded file to a new location.
OpenStream | Opens the uploaded file's data stream.
Persist | Persists this instance.
ToString (inherited from Object) |
Protected Instance Methods
Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
See Also

PersistedFile Class | CuteWebUI Namespace


ProgressBarType Enumeration

Specifies the style that a ProgressBar uses to indicate the progress of an operation.

[Visual Basic]
Public Enum ProgressBarType
[C#]
public enum ProgressBarType
Members
Member Name | Description
Blocks | Indicates progress by increasing the number of segmented blocks in a ProgressBar.
Continuous | Indicates progress by increasing the size of a smooth, continuous bar in a ProgressBar.
Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

CuteWebUI Namespace


UploadAttachments Class

This class allows you upload multiple files with a single element. The uploaded file will be added to the list of attachments. Just the way Gmail does for email attachment.

For a list of all members of this type, see UploadAttachments Members.

System.Object
System.Web.UI.Control
CuteWebUI.UploaderBase
CuteWebUI.Uploader
CuteWebUI.UploadFileBase
CuteWebUI.UploadAttachments

[Visual Basic]
Public Class UploadAttachments
Inherits UploadFileBase
[C#]
public class UploadAttachments : UploadFileBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

UploadAttachments Members | CuteWebUI Namespace


UploadAttachments._customProvider Field

[Visual Basic]
Protected Friend _customProvider As IAttachmentProvider
[C#]
protected internal IAttachmentProvider _customProvider;

See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments._headerRowStyle Field

[Visual Basic]
Protected Friend _headerRowStyle As TableItemStyle
[C#]
protected internal TableItemStyle _headerRowStyle;

See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments._itemCellStyle Field

[Visual Basic]
Protected Friend _itemCellStyle As TableItemStyle
[C#]
protected internal TableItemStyle _itemCellStyle;

See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments._itemCheckStyle Field

[Visual Basic]
Protected Friend _itemCheckStyle As Style
[C#]
protected internal Style _itemCheckStyle;

See Also

UploadAttachments Class | CuteWebUI Namespace


ActionButtonBehavior Property

PHP File Uploader Class Reference

UploadAttachments.ActionButtonBehavior Property

Specify the default behavior when user click the remove button on an attachment item

[Visual Basic]
Public Property ActionButtonBehavior As AttachmentItemBehavior
[C#]
public AttachmentItemBehavior ActionButtonBehavior {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


ActionButtonText Property

PHP File Uploader Class Reference

UploadAttachments.ActionButtonText Property

Gets or sets Action Button Text.

[Visual Basic]
Public Property ActionButtonText As String
[C#]
public string ActionButtonText {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.AddCustomAttachment Method

Adds the custom attachment.

[Visual Basic]
Public Sub AddCustomAttachment( _
ByVal fileguid As Guid _
)
[C#]
public void AddCustomAttachment(
Guid fileguid
);
Parameters
fileguid
The file guid.
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.AttachmentActionClicked Event

Occurs when the user click the item action button.

[Visual Basic]
Public Event AttachmentActionClicked As AttachmentItemEventHandler
[C#]
public event AttachmentItemEventHandler AttachmentActionClicked;

Event Data

The event handler receives an argument of type AttachmentItemEventArgs containing data related to this event. The following AttachmentItemEventArgs properties provide information specific to this event.

Property | Description
Behavior | provide more option for AttachmentRemoveClicked/ActionButtonClicked event.
Item | Gets the item.
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.AttachmentAdded Event

Occurs when attachment be uploaded.

[Visual Basic]
Public Event AttachmentAdded As AttachmentItemEventHandler
[C#]
public event AttachmentItemEventHandler AttachmentAdded;

Event Data

The event handler receives an argument of type AttachmentItemEventArgs containing data related to this event. The following AttachmentItemEventArgs properties provide information specific to this event.

Property | Description
Behavior | provide more option for AttachmentRemoveClicked/ActionButtonClicked event.
Item | Gets the item.
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.AttachmentCheckChanged Event

Occurs when attachment check changed.

[Visual Basic]
Public Event AttachmentCheckChanged As AttachmentItemEventHandler
[C#]
public event AttachmentItemEventHandler AttachmentCheckChanged;

Event Data

The event handler receives an argument of type AttachmentItemEventArgs containing data related to this event. The following AttachmentItemEventArgs properties provide information specific to this event.

Property | Description
Behavior | provide more option for AttachmentRemoveClicked/ActionButtonClicked event.
Item | Gets the item.
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.AttachmentCreated Event

Occurs when attachment control created.

[Visual Basic]
Public Event AttachmentCreated As AttachmentItemEventHandler
[C#]
public event AttachmentItemEventHandler AttachmentCreated;

Event Data

The event handler receives an argument of type AttachmentItemEventArgs containing data related to this event. The following AttachmentItemEventArgs properties provide information specific to this event.

Property | Description
Behavior | provide more option for AttachmentRemoveClicked/ActionButtonClicked event.
Item | Gets the item.
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.AttachmentDataBound Event

Occurs when attachment control data bound.

[Visual Basic]
Public Event AttachmentDataBound As AttachmentItemEventHandler
[C#]
public event AttachmentItemEventHandler AttachmentDataBound;

Event Data

The event handler receives an argument of type AttachmentItemEventArgs containing data related to this event. The following AttachmentItemEventArgs properties provide information specific to this event.

Property | Description
Behavior | provide more option for AttachmentRemoveClicked/ActionButtonClicked event.
Item | Gets the item.
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.AttachmentHided Event

Occurs when the user click the item remove button.

[Visual Basic]
Public Event AttachmentHided As AttachmentItemEventHandler
[C#]
public event AttachmentItemEventHandler AttachmentHided;

Event Data

The event handler receives an argument of type AttachmentItemEventArgs containing data related to this event. The following AttachmentItemEventArgs properties provide information specific to this event.

Property | Description
Behavior | provide more option for AttachmentRemoveClicked/ActionButtonClicked event.
Item | Gets the item.
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.AttachmentRemoveClicked Event

Occurs when the user click the item remove button.

[Visual Basic]
Public Event AttachmentRemoveClicked As AttachmentItemEventHandler
[C#]
public event AttachmentItemEventHandler AttachmentRemoveClicked;

Event Data

The event handler receives an argument of type AttachmentItemEventArgs containing data related to this event. The following AttachmentItemEventArgs properties provide information specific to this event.

Property | Description
Behavior | provide more option for AttachmentRemoveClicked/ActionButtonClicked event.
Item | Gets the item.
See Also

UploadAttachments Class | CuteWebUI Namespace


AttachmentTableStyle Property

PHP File Uploader Class Reference

UploadAttachments.AttachmentTableStyle Property

Specifies the style for the attachment table.

[Visual Basic]
Public Property AttachmentTableStyle As String
[C#]
public string AttachmentTableStyle {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


AttachmentTRStyle Property

PHP File Uploader Class Reference

UploadAttachments.AttachmentTRStyle Property

Specifies the style for rows of the attachment table.

[Visual Basic]
Public Property AttachmentTRStyle As String
[C#]
public string AttachmentTRStyle {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.CreateAttachmentItem Method

[Visual Basic]
Overridable Protected Function CreateAttachmentItem() As AttachmentItem
[C#]
protected virtual AttachmentItem CreateAttachmentItem();
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.CreateChildControls Method

[Visual Basic]
Overrides Protected Sub CreateChildControls()
[C#]
protected override void CreateChildControls();
See Also

UploadAttachments Class | CuteWebUI Namespace


CustomProvider Property

PHP File Uploader Class Reference

UploadAttachments.CustomProvider Property

Gets or sets the custom provider.

[Visual Basic]
Public Property CustomProvider As IAttachmentProvider
[C#]
public IAttachmentProvider CustomProvider {get; set;}

Property Value

The custom provider.

See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.DeleteAllAttachments Method

Deletes all attachments.

[Visual Basic]
Public Sub DeleteAllAttachments()
[C#]
public void DeleteAllAttachments();
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.DeleteAttachment Method

Deletes the specified attachment.

[Visual Basic]
Public Sub DeleteAttachment( _
ByVal index As Integer _
)
[C#]
public void DeleteAttachment(
int index
);
Parameters
index
The index.
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.DeleteUncheckedAttachments Method

Deletes the unchecked attachments.

[Visual Basic]
Public Sub DeleteUncheckedAttachments()
[C#]
public void DeleteUncheckedAttachments();
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.GetAttachmentCount Method

Gets the attachment count.

[Visual Basic]
Public Function GetAttachmentCount() As Integer
[C#]
public int GetAttachmentCount();
Return Value

See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.GetItemsTable Method

Get the table for items.

[Visual Basic]
Public Function GetItemsTable() As WebControl
[C#]
public WebControl GetItemsTable();
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.GetUploadedFileCount Method

[Visual Basic]
Overrides Protected Function GetUploadedFileCount() As Integer
[C#]
protected override int GetUploadedFileCount();
See Also

UploadAttachments Class | CuteWebUI Namespace


HeaderRowStyle Property

PHP File Uploader Class Reference

UploadAttachments.HeaderRowStyle Property

Gets the header row style.

[Visual Basic]
Public ReadOnly Property HeaderRowStyle As TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle HeaderRowStyle {get;}

Property Value

The header row style.

See Also

UploadAttachments Class | CuteWebUI Namespace


HideNoItemTable Property

PHP File Uploader Class Reference

UploadAttachments.HideNoItemTable Property

Gets or sets a value indicating whether [hide no item table].

[Visual Basic]
Public Property HideNoItemTable As Boolean
[C#]
public bool HideNoItemTable {get; set;}

Property Value

true if [hide no item table]; otherwise, false.

See Also

UploadAttachments Class | CuteWebUI Namespace


InsertText Property

PHP File Uploader Class Reference

UploadAttachments.InsertText Property

Gets or sets the insert text.

[Visual Basic]
Overrides Public Property InsertText As String
[C#]
public override string InsertText {get; set;}

Property Value

The insert text.

See Also

UploadAttachments Class | CuteWebUI Namespace


ItemCellStyle Property

PHP File Uploader Class Reference

UploadAttachments.ItemCellStyle Property

Gets the item cell style.

[Visual Basic]
Public ReadOnly Property ItemCellStyle As TableItemStyle
[C#]
public System.Web.UI.WebControls.TableItemStyle ItemCellStyle {get;}

Property Value

The item cell style.

See Also

UploadAttachments Class | CuteWebUI Namespace


ItemCheckStyle Property

PHP File Uploader Class Reference

UploadAttachments.ItemCheckStyle Property

Gets the item check style.

[Visual Basic]
Public ReadOnly Property ItemCheckStyle As Style
[C#]
public System.Web.UI.WebControls.Style ItemCheckStyle {get;}

Property Value

The item check style.

See Also

UploadAttachments Class | CuteWebUI Namespace


Items Property

PHP File Uploader Class Reference

UploadAttachments.Items Property

Get the uploaded files list.

[Visual Basic]
Public ReadOnly Property Items As AttachmentItemCollection
[C#]
public AttachmentItemCollection Items {get;}

See Also

UploadAttachments Class | CuteWebUI Namespace


ItemTemplate Property

PHP File Uploader Class Reference

UploadAttachments.ItemTemplate Property

[Visual Basic]
Public Property ItemTemplate As ITemplate
[C#]
public System.Web.UI.ITemplate ItemTemplate {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


ItemTemplatePosition Property

PHP File Uploader Class Reference

UploadAttachments.ItemTemplatePosition Property

Gets or sets the item template position.

[Visual Basic]
Public Property ItemTemplatePosition As AttachmentItemTemplatePosition
[C#]
public AttachmentItemTemplatePosition ItemTemplatePosition {get; set;}

Property Value

The item template position.

See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.LoadViewState Method

[Visual Basic]
Overrides Protected Sub LoadViewState( _
ByVal savedState As Object _
)
[C#]
protected override void LoadViewState(
object savedState
);
See Also

UploadAttachments Class | CuteWebUI Namespace


MultipleFilesUpload Property

PHP File Uploader Class Reference

UploadAttachments.MultipleFilesUpload Property

[Visual Basic]
Overrides Public Property MultipleFilesUpload As Boolean
[C#]
public override bool MultipleFilesUpload {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.OnAttachmentActionClicked Method

[Visual Basic]
Overridable Protected Friend Sub OnAttachmentActionClicked( _
ByVal args As AttachmentItemEventArgs _
)
[C#]
protected internal virtual void OnAttachmentActionClicked(
AttachmentItemEventArgs args
);
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.OnAttachmentAdded Method

[Visual Basic]
Overridable Protected Sub OnAttachmentAdded( _
ByVal args As AttachmentItemEventArgs _
)
[C#]
protected virtual void OnAttachmentAdded(
AttachmentItemEventArgs args
);
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.OnAttachmentCheckChanged Method

[Visual Basic]
Overridable Protected Sub OnAttachmentCheckChanged( _
ByVal args As AttachmentItemEventArgs _
)
[C#]
protected virtual void OnAttachmentCheckChanged(
AttachmentItemEventArgs args
);
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.OnAttachmentCreated Method

[Visual Basic]
Overridable Protected Sub OnAttachmentCreated( _
ByVal args As AttachmentItemEventArgs _
)
[C#]
protected virtual void OnAttachmentCreated(
AttachmentItemEventArgs args
);
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.OnAttachmentDataBound Method

[Visual Basic]
Overridable Protected Sub OnAttachmentDataBound( _
ByVal args As AttachmentItemEventArgs _
)
[C#]
protected virtual void OnAttachmentDataBound(
AttachmentItemEventArgs args
);
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.OnAttachmentHided Method

[Visual Basic]
Overridable Protected Friend Sub OnAttachmentHided( _
ByVal args As AttachmentItemEventArgs _
)
[C#]
protected internal virtual void OnAttachmentHided(
AttachmentItemEventArgs args
);
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.OnAttachmentRemoveClicked Method

[Visual Basic]
Overridable Protected Friend Sub OnAttachmentRemoveClicked( _
ByVal args As AttachmentItemEventArgs _
)
[C#]
protected internal virtual void OnAttachmentRemoveClicked(
AttachmentItemEventArgs args
);
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.OnFileUploaded Method

[Visual Basic]
Overrides Protected Sub OnFileUploaded( _
ByVal args As PhpUploadFile _
)
[C#]
protected override void OnFileUploaded(
PhpUploadFile args
);
See Also

UploadAttachments Class | CuteWebUI Namespace


RemoveButtonBehavior Property

PHP File Uploader Class Reference

UploadAttachments.RemoveButtonBehavior Property

Specify the default behavior when user click the remove button on an attachment item

[Visual Basic]
Public Property RemoveButtonBehavior As AttachmentItemBehavior
[C#]
public AttachmentItemBehavior RemoveButtonBehavior {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


RemoveButtonText Property

PHP File Uploader Class Reference

UploadAttachments.RemoveButtonText Property

Gets or sets Remove Button Text.

[Visual Basic]
Public Property RemoveButtonText As String
[C#]
public string RemoveButtonText {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.Render Method

[Visual Basic]
Overrides Protected Sub Render( _
ByVal writer As HtmlTextWriter _
)
[C#]
protected override void Render(
HtmlTextWriter writer
);
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.RenderDesignMode Method

[Visual Basic]
Overrides Protected Sub RenderDesignMode( _
ByVal writer As HtmlTextWriter _
)
[C#]
protected override void RenderDesignMode(
HtmlTextWriter writer
);
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.SaveViewState Method

[Visual Basic]
Overrides Protected Function SaveViewState() As Object
[C#]
protected override object SaveViewState();
See Also

UploadAttachments Class | CuteWebUI Namespace


ShowActionButtons Property

PHP File Uploader Class Reference

UploadAttachments.ShowActionButtons Property

Gets or sets a value indicating whether [show Action icons].

[Visual Basic]
Public Property ShowActionButtons As Boolean
[C#]
public bool ShowActionButtons {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


ShowCheckBoxes Property

PHP File Uploader Class Reference

UploadAttachments.ShowCheckBoxes Property

Gets or sets a value indicating whether [show checkboxes].

[Visual Basic]
Public Property ShowCheckBoxes As Boolean
[C#]
public bool ShowCheckBoxes {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


ShowFileIcons Property

PHP File Uploader Class Reference

UploadAttachments.ShowFileIcons Property

Gets or sets a value indicating whether [show file icons].

[Visual Basic]
Public Property ShowFileIcons As Boolean
[C#]
public bool ShowFileIcons {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


ShowRemoveButtons Property

PHP File Uploader Class Reference

UploadAttachments.ShowRemoveButtons Property

Gets or sets a value indicating whether [show Remove icons].

[Visual Basic]
Public Property ShowRemoveButtons As Boolean
[C#]
public bool ShowRemoveButtons {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


ShowTableHeader Property

PHP File Uploader Class Reference

UploadAttachments.ShowTableHeader Property

Specifies whether the Table Header appear.

[Visual Basic]
Public Property ShowTableHeader As Boolean
[C#]
public bool ShowTableHeader {get; set;}

See Also

UploadAttachments Class | CuteWebUI Namespace


TableHeaderTemplate Property

PHP File Uploader Class Reference

UploadAttachments.TableHeaderTemplate Property

Gets or sets the table header template.

[Visual Basic]
Public Property TableHeaderTemplate As String
[C#]
public string TableHeaderTemplate {get; set;}

Property Value

The table header template.

See Also

UploadAttachments Class | CuteWebUI Namespace


TableStyle Property

PHP File Uploader Class Reference

UploadAttachments.TableStyle Property

Gets the table style.

[Visual Basic]
Public ReadOnly Property TableStyle As TableStyle
[C#]
public System.Web.UI.WebControls.TableStyle TableStyle {get;}

Property Value

The table style.

See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.TrackViewState Method

[Visual Basic]
Overrides Protected Sub TrackViewState()
[C#]
protected override void TrackViewState();
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments.UpdateItemCount Method

[Visual Basic]
Protected Friend Sub UpdateItemCount()
[C#]
protected internal void UpdateItemCount();
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments Constructor

Initializes a new instance of the UploadAttachments class.

[Visual Basic]
Public Sub New()
[C#]
public UploadAttachments();
See Also

UploadAttachments Class | CuteWebUI Namespace


UploadAttachments Members

UploadAttachments overview

Public Instance Constructors
UploadAttachments Constructor Initializes a new instance of the UploadAttachments class.
Public Instance Properties
ActionButtonBehavior | Specify the default behavior when user click the remove button on an attachment item
ActionButtonText | Gets or sets Action Button Text.
AttachmentTableStyle | Specifies the style for the attachment table.
AttachmentTRStyle | Specifies the style for rows of the attachment table.
AutoUseSystemTempFolder (inherited from UploaderBase) | A system temporary folder or temporary directory is a directory used to hold temporary files. By default, when PHP File Uploader detects TempDirectory propery is not set, it will automatically use the system temporary folder. if web.config sepcified the TempDirectory appSetting, this would not take effects. You can turn this feature off by setting it to "false".
BindingContainer (inherited from Control) |
ButtonOnClickScript (inherited from UploaderBase) | JavaScript code that be executed when the browse button be clicked.
CancelAllMsg (inherited from UploaderBase) | Gets or sets the "Cancel all Uploads" message.
CancelButton (inherited from Uploader) |
CancelButtonID (inherited from UploaderBase) | It allows the developers specify a server control to use as the cancel button of PHP File Uploader.
CancelButtonStyle (inherited from Uploader) | Gets the cancel button style.
CancelText (inherited from Uploader) | Gets or sets the cancel text.
CancelUploadMsg (inherited from UploaderBase) | Gets or sets the "Cancel upload" message.
ClientID (inherited from Control) |
Controls (inherited from Control) |
CustomProvider | Gets or sets the custom provider.
DialogFilter (inherited from UploaderBase) | Gets or sets the current file name filter string, which determines the choices that appear in the file browser dialog box. Please note that only ValidateOption.AllowedFileExtensions property determine the allowed file extensions for uploading.
DirtyText (inherited from UploadFileBase) | Gets or sets the dirty text.
EnableViewState (inherited from Control) |
FileTooLargeMsg (inherited from UploaderBase) | Gets or sets the "File too large" message.
FileTypeNotSupportMsg (inherited from UploaderBase) | Gets or sets the "file type not support" message.
FlashUploadPage (inherited from UploaderBase) | set a special page for Flash - Integrated Windows Authentication chould be also set to web.config appSettings : CuteWebUI.AjaxUploader.FlashUploadPage (CuteEditor.AjaxUploader.FlashUploadPage for CuteEditor)
FlashWarningImage (inherited from UploaderBase) | Gets or sets the FlashWarning Image.
HeaderRowStyle | Gets the header row style.
HideNoItemTable | Gets or sets a value indicating whether [hide no item table].
ID (inherited from Control) |
InputboxCSSText (inherited from UploaderBase) | Sets or retrieves the appearance of the file input control.
InsertButton (inherited from Uploader) |
InsertButtonID (inherited from UploaderBase) | It allows the developers specify a server control to use as the insert button of PHP File Uploader.
InsertButtonStyle (inherited from Uploader) | Gets the insert button style.
InsertText | Gets or sets the insert text.
ItemCellStyle | Gets the item cell style.
ItemCheckStyle | Gets the item check style.
ItemLabelStyle (inherited from UploadFileBase) | Gets the item label style.
Items | Get the uploaded files list.
ItemTemplate |
ItemTemplatePosition | Gets or sets the item template position.
ItemTextTemplate (inherited from UploadFileBase) | Gets or sets the item text template.
ManualStartUpload (inherited from UploaderBase) | Gets or sets a boolean indicating whether Uploader automatically starts uploading as soon as a user selects a file.
MaxFilesLimit (inherited from UploaderBase) | Gets or sets the maximum number of files that can be uploaded.
MaxFilesLimitMsg (inherited from UploaderBase) | Gets or sets the "File too large" message.
MultipleFilesUpload |
NamingContainer (inherited from Control) |
NumFilesShowCancelAll (inherited from UploaderBase) |
Page (inherited from Control) |
Parent (inherited from Control) |
ProgressBarBackgroundImage (inherited from UploaderBase) | Gets or sets the background image for the ProgressBar control.
ProgressBarBorderStyle (inherited from UploaderBase) | Specifies the border style for the ProgressBar control.
ProgressBarHeight (inherited from UploaderBase) | The height of the Progress bar. Default is 15.
ProgressBarStyle (inherited from UploaderBase) | Specifies the style that a ProgressBar uses to indicate the progress of an operation.
ProgressCtrlID (inherited from UploaderBase) | It allows the developers specify a server control to use as the progress control of PHP File Uploader.
ProgressInfoStyle (inherited from UploaderBase) | The style to be applied to the progress information.
ProgressLabel (inherited from Uploader) |
ProgressLabelStyle (inherited from Uploader) | Gets the progress label style.
ProgressPanel (inherited from Uploader) |
ProgressPanelStyle (inherited from Uploader) | Gets the progress panel style.
ProgressPanelWidth (inherited from UploaderBase) | The width of the Progress Panel. Default is 500.
ProgressPicture (inherited from UploaderBase) | Gets or sets a progress fill picture for the ProgressBar control.
ProgressTextID (inherited from UploaderBase) | It allows the developers specify a server control to show the progress text of PHP File Uploader.
ProgressTextTemplate (inherited from UploaderBase) | Gets or sets the progress text template. %P% = percent,%T% = seconds remain,%F% = filename. %SEND% = uploaded size , %SIZE% = file size , %KBPS% means KB/s , %KBPS% = B/s For example : %F%.. %P% %SEND%/%SIZE% , %KBPS% , %T% seconds left.
RemoveButtonBehavior | Specify the default behavior when user click the remove button on an attachment item
RemoveButtonText | Gets or sets Remove Button Text.
ShowActionButtons | Gets or sets a value indicating whether [show Action icons].
ShowCheckBoxes | Gets or sets a value indicating whether [show checkboxes].
ShowFileIcons | Gets or sets a value indicating whether [show file icons].
ShowFrameBrowseButton (inherited from UploaderBase) | Gets or sets a boolean indicating whether Uploader should render a browse button for FireFox/Opera in Iframe Mode.
ShowProgressBar (inherited from UploaderBase) | Gets or sets a value indicating whether the progress bar is displayed. The UploadModule must be installed to use this feature.
ShowProgressInfo (inherited from UploaderBase) | Gets or sets a value indicating whether the progress information is displayed when uploading. The UploadModule must be installed to use this feature.
ShowRemoveButtons | Gets or sets a value indicating whether [show Remove icons].
ShowTableHeader | Specifies whether the Table Header appear.
Site (inherited from Control) |
TableHeaderTemplate | Gets or sets the table header template.
TableStyle | Gets the table style.
TempDirectory (inherited from UploaderBase) | Specifies where AjaxUploader should put the temporary files.
TemplateSourceDirectory (inherited from Control) |
UniqueID (inherited from Control) |
UploadingMsg (inherited from UploaderBase) | Gets or sets the "Uploading.." message.
UploadProcessingMsg (inherited from UploaderBase) | Gets or sets the "upload is processing" message.
UploadType (inherited from UploaderBase) | The global type of upload method to use.
ValidateOption (inherited from UploaderBase) | Gets the validate option.
Visible (inherited from Control) |
WindowsDialogLimitMsg (inherited from UploaderBase) | Gets or sets the message for windows file browse dialog 32K file name length limitation.
Public Instance Methods
AddCustomAttachment | Adds the custom attachment.
DataBind (inherited from Control) |
DeleteAllAttachments | Deletes all attachments.
DeleteAttachment | Deletes the specified attachment.
DeleteUncheckedAttachments | Deletes the unchecked attachments.
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) | Overloaded.
GetAdvancedOption (inherited from UploaderBase) | Overloaded.
GetAttachmentCount | Gets the attachment count.
GetHashCode (inherited from Object) |
GetItemsTable | Get the table for items.
GetType (inherited from Object) |
GetUploaderProvider (inherited from UploaderBase) | Gets the uploader provider instance to handle file data.
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetAdvancedOption (inherited from UploaderBase) | Overloaded.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |
Upload (inherited from UploaderBase) | Overloaded. Use server file to simulate file uploading and uploaded event. This method affects all child types.
Public Instance Events
AttachmentActionClicked | Occurs when the user click the item action button.
AttachmentAdded | Occurs when attachment be uploaded.
AttachmentCheckChanged | Occurs when attachment check changed.
AttachmentCreated | Occurs when attachment control created.
AttachmentDataBound | Occurs when attachment control data bound.
AttachmentHided | Occurs when the user click the item remove button.
AttachmentRemoveClicked | Occurs when the user click the item remove button.
DataBinding (inherited from Control) |
Disposed (inherited from Control) |
FileUploaded (inherited from UploaderBase) | fired when a file are uploaded and validated
FileValidating (inherited from UploaderBase) | attach custom code to validate the uploading file
Init (inherited from Control) |
Load (inherited from Control) |
PreRender (inherited from Control) |
Unload (inherited from Control) |
Protected Instance Properties
ChildControlsCreated (inherited from Control) |
Context (inherited from Control) |
Events (inherited from Control) |
HasChildViewState (inherited from Control) |
IsBrowserSupportUploadScript (inherited from UploaderBase) | detect whether the browser support the script upload
IsDesignMode (inherited from UploaderBase) |
IsTrackingViewState (inherited from Control) |
ViewState (inherited from Control) |
ViewStateIgnoresCase (inherited from Control) |
Protected Instance Methods
AddControlIDToAttribute (inherited from Uploader) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateAttachmentItem |
CreateChildControls |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) | Overloaded.
GetAdvancedOption (inherited from UploaderBase) | Overloaded.
GetUploadedFileCount |
IsLiteralContent (inherited from Control) |
LoadViewState |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnAttachmentAdded |
OnAttachmentCheckChanged |
OnAttachmentCreated |
OnAttachmentDataBound |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnFileUploaded |
OnFileValidating (inherited from UploaderBase) |
OnInit (inherited from UploaderBase) |
OnLoad (inherited from UploaderBase) |
OnPreRender (inherited from UploaderBase) | OnPreRender
OnUnload (inherited from UploaderBase) |
RaiseBubbleEvent (inherited from Control) |
Render |
RenderChildren (inherited from Uploader) |
RenderDesignMode |
RenderInsertButton (inherited from Uploader) |
RenderProgressCtrl (inherited from Uploader) |
SaveViewState |
SetAdvancedOption (inherited from UploaderBase) | Overloaded.
TrackViewState |
Protected Internal Instance Fields
_customProvider
_headerRowStyle
_itemCellStyle
_itemCheckStyle
_itemLabelStyle (inherited from UploadFileBase)
Protected Internal Instance Methods
AddedControl (inherited from Control)
OnAttachmentActionClicked
OnAttachmentHided
OnAttachmentRemoveClicked
RemovedControl (inherited from Control)
UpdateItemCount
See Also

UploadAttachments Class | CuteWebUI Namespace


Uploader.AddControlIDToAttribute Method

[Visual Basic]
Overrides Protected Sub AddControlIDToAttribute( _
ByVal writer As HtmlTextWriter, _
ByVal browseid As String, _
ByVal buttonName As String _
)
[C#]
protected override void AddControlIDToAttribute(
HtmlTextWriter writer,
string browseid,
string buttonName
);
See Also

Uploader Class | CuteWebUI Namespace


CancelButton Property

PHP File Uploader Class Reference

Uploader.CancelButton Property

Gets or sets the allowed file extensions for uploading.

Example Code

  1. <?php require_once "phpuploader/include_phpuploader.php" ?>
  2. <html>
  3. <body>
  4. <form id="form1" method="POST">
  5. <?php
  6. $uploader=new PhpUploader();
  7. $uploader->Name="myuploader";
  8. $uploader->CancelButtonID="uploadercancelbutton";
  9. $uploader->Render();
  10. ?>
  11. <img id="uploadercancelbutton" style='display:none;' alt="Cancel" src="sampleimages/cancel_button.gif" />
  12. </form>
  13. </body>
  14. </html>
am>


CancelButtonStyle Property

PHP File Uploader Class Reference

Uploader.CancelButtonStyle Property

Gets the cancel button style.

[Visual Basic]
Public ReadOnly Property CancelButtonStyle As Style
[C#]
public System.Web.UI.WebControls.Style CancelButtonStyle {get;}

Property Value

The cancel button style.

See Also

Uploader Class | CuteWebUI Namespace


CancelText Property

PHP File Uploader Class Reference

Uploader.CancelText Property

Gets or sets the cancel text.

[Visual Basic]
Public Property CancelText As String
[C#]
public string CancelText {get; set;}

Property Value

The cancel text.

See Also

Uploader Class | CuteWebUI Namespace


InsertButton Property

PHP File Uploader Class Reference

Uploader.InsertButton Property

[Visual Basic]
Public ReadOnly Property InsertButton As Button
[C#]
public System.Web.UI.WebControls.Button InsertButton {get;}

See Also

Uploader Class | CuteWebUI Namespace


InsertButtonStyle Property

PHP File Uploader Class Reference

Uploader.InsertButtonStyle Property

Gets the insert button style.

[Visual Basic]
Public ReadOnly Property InsertButtonStyle As Style
[C#]
public System.Web.UI.WebControls.Style InsertButtonStyle {get;}

Property Value

The insert button style.

See Also

Uploader Class | CuteWebUI Namespace


InsertText Property

PHP File Uploader Class Reference

Uploader.InsertText Property

Gets or sets the insert text.

[Visual Basic]
Overrides Public Property InsertText As String
[C#]
public override string InsertText {get; set;}

Property Value

The insert text.

See Also

Uploader Class | CuteWebUI Namespace


ProgressLabel Property

PHP File Uploader Class Reference

Uploader.ProgressLabel Property

[Visual Basic]
Public ReadOnly Property ProgressLabel As Label
[C#]
public System.Web.UI.WebControls.Label ProgressLabel {get;}

See Also

Uploader Class | CuteWebUI Namespace


ProgressLabelStyle Property

PHP File Uploader Class Reference

Uploader.ProgressLabelStyle Property

Gets the progress label style.

[Visual Basic]
Public ReadOnly Property ProgressLabelStyle As Style
[C#]
public System.Web.UI.WebControls.Style ProgressLabelStyle {get;}

Property Value

The progress label style.

See Also

Uploader Class | CuteWebUI Namespace


ProgressPanel Property

PHP File Uploader Class Reference

Uploader.ProgressPanel Property

[Visual Basic]
Public ReadOnly Property ProgressPanel As Panel
[C#]
public System.Web.UI.WebControls.Panel ProgressPanel {get;}

See Also

Uploader Class | CuteWebUI Namespace


ProgressPanelStyle Property

PHP File Uploader Class Reference

Uploader.ProgressPanelStyle Property

Gets the progress panel style.

[Visual Basic]
Public ReadOnly Property ProgressPanelStyle As Style
[C#]
public System.Web.UI.WebControls.Style ProgressPanelStyle {get;}

Property Value

The progress panel style.

See Also

Uploader Class | CuteWebUI Namespace


Uploader.RenderChildren Method

[Visual Basic]
Overrides Protected Sub RenderChildren( _
ByVal writer As HtmlTextWriter _
)
[C#]
protected override void RenderChildren(
HtmlTextWriter writer
);
See Also

Uploader Class | CuteWebUI Namespace


Uploader.RenderDesignMode Method

[Visual Basic]
Overrides Protected Sub RenderDesignMode( _
ByVal writer As HtmlTextWriter _
)
[C#]
protected override void RenderDesignMode(
HtmlTextWriter writer
);
See Also

Uploader Class | CuteWebUI Namespace


Uploader.RenderInsertButton Method

[Visual Basic]
Overridable Protected Sub RenderInsertButton( _
ByVal writer As HtmlTextWriter _
)
[C#]
protected virtual void RenderInsertButton(
HtmlTextWriter writer
);
See Also

Uploader Class | CuteWebUI Namespace


Uploader.RenderProgressCtrl Method

[Visual Basic]
Overridable Protected Sub RenderProgressCtrl( _
ByVal writer As HtmlTextWriter _
)
[C#]
protected virtual void RenderProgressCtrl(
HtmlTextWriter writer
);
See Also

Uploader Class | CuteWebUI Namespace


UploaderAdvancedOption Enumeration

This enumeration is used by Uploader.SetAdvancedOption.

[Visual Basic]
Public Enum UploaderAdvancedOption
[C#]
public enum UploaderAdvancedOption
Members
Member Name | Description
NoSilverlight | Disables Silverlight.
NoFlash | Disables Flash.
NoFlash10 | Disables Flash version 10.
NoFlash89 | Disables Flash version 8 and version 9.
NoFlash8 | Disables Flash version 8.
NoFlash9 | Disables Flash version 9.
Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

CuteWebUI Namespace


PhpUploadFile Constructor

PHP File Uploader Class Reference

UploaderEventArgs Constructor

Initializes a new instance of the PhpUploadFile class.

Overload List

Initializes a new instance of the PhpUploadFile class.

public UploaderEventArgs(UploaderBase,Guid);

Initializes a new instance of the PhpUploadFile class.

public UploaderEventArgs(UploaderBase,Guid,string);

Initializes a new instance of the PhpUploadFile class.

public UploaderEventArgs(UploaderBase,Guid,string,int);
See Also

PhpUploadFile Class | CuteWebUI Namespace


PhpUploadFile Constructor (UploaderBase, Guid)

PHP File Uploader Class Reference

UploaderEventArgs Constructor (UploaderBase, Guid)

Initializes a new instance of the PhpUploadFile class.

[Visual Basic]
Overloads Public Sub New( _
ByVal uploader As UploaderBase, _
ByVal guid As Guid _
)
[C#]
public UploaderEventArgs(
UploaderBase uploader,
Guid guid
);
Parameters
uploader
The uploader.
guid
The GUID.
See Also

PhpUploadFile Class | CuteWebUI Namespace | PhpUploadFile Constructor Overload List


PhpUploadFile Constructor (UploaderBase, Guid, String)

PHP File Uploader Class Reference

UploaderEventArgs Constructor (UploaderBase, Guid, String)

Initializes a new instance of the PhpUploadFile class.

[Visual Basic]
Overloads Public Sub New( _
ByVal uploader As UploaderBase, _
ByVal guid As Guid, _
ByVal filename As String _
)
[C#]
public UploaderEventArgs(
UploaderBase uploader,
Guid guid,
string filename
);
Parameters
uploader
The uploader.
guid
The GUID.
filename
The filename.
See Also

PhpUploadFile Class | CuteWebUI Namespace | PhpUploadFile Constructor Overload List


PhpUploadFile Constructor (UploaderBase, Guid, String, Int32)

PHP File Uploader Class Reference

UploaderEventArgs Constructor (UploaderBase, Guid, String, Int32)

Initializes a new instance of the PhpUploadFile class.

[Visual Basic]
Overloads Public Sub New( _
ByVal uploader As UploaderBase, _
ByVal guid As Guid, _
ByVal filename As String, _
ByVal filesize As Integer _
)
[C#]
public UploaderEventArgs(
UploaderBase uploader,
Guid guid,
string filename,
int filesize
);
Parameters
uploader
The uploader.
guid
The GUID.
filename
The filename.
filesize
The filesize.
See Also

PhpUploadFile Class | CuteWebUI Namespace | PhpUploadFile Constructor Overload List


PhpUploadFile Members

PhpUploadFile overview

Public Instance Constructors
PhpUploadFile Overloaded. Initializes a new instance of the PhpUploadFile class.
Public Instance Properties
FileGuid | Gets the GUID of the file.
FileName | Gets the name of the file.
FileSize | Gets the size of the file.
Public Instance Methods
CopyTo | Copys the uploaded file to a new location.
Delete | Deletes this instance.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetTempFilePath | Gets the temp file path.
GetType (inherited from Object) |
MoveTo | Moves the uploaded file to a new location.
OpenStream | Opens the uploaded file's data stream.
Persist | Persists this instance.
ToString (inherited from Object) |
Protected Instance Methods
Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
See Also

PhpUploadFile Class | CuteWebUI Namespace


UploaderEventHandler Delegate

Represents the method that will handle Uploader control events.

[Visual Basic]
Public Delegate Sub UploaderEventHandler( _
ByVal sender As Object, _
ByVal args As PhpUploadFile _
)
[C#]
public delegate void UploaderEventHandler(
object sender,
PhpUploadFile args
);
Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

CuteWebUI Namespace


UploaderLicenseException Class

For a list of all members of this type, see UploaderLicenseException Members.

System.Object
System.Exception
CuteWebUI.UploaderLicenseException

[Visual Basic]
Public Class UploaderLicenseException
Inherits Exception
[C#]
public class UploaderLicenseException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

UploaderLicenseException Members | CuteWebUI Namespace


UploaderLicenseException.GetObjectData Method

[Visual Basic]
Overrides Public Sub GetObjectData( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
) _
Implements ISerializable.GetObjectData
[C#]
public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);
Implements

ISerializable.GetObjectData

See Also

UploaderLicenseException Class | CuteWebUI Namespace


LicenseType Property

PHP File Uploader Class Reference

UploaderLicenseException.LicenseType Property

[Visual Basic]
Public ReadOnly Property LicenseType As EnumUploaderLicense
[C#]
public EnumUploaderLicense LicenseType {get;}

See Also

UploaderLicenseException Class | CuteWebUI Namespace


UploaderLicenseException Constructor

Overload List

public UploaderLicenseException(EnumUploaderLicense,Exception);

protected UploaderLicenseException(SerializationInfo,StreamingContext);
See Also

UploaderLicenseException Class | CuteWebUI Namespace


UploaderLicenseException Constructor (EnumUploaderLicense, Exception)

[Visual Basic]
Overloads Public Sub New( _
ByVal licenseType As EnumUploaderLicense, _
ByVal innerException As Exception _
)
[C#]
public UploaderLicenseException(
EnumUploaderLicense licenseType,
Exception innerException
);
See Also

UploaderLicenseException Class | CuteWebUI Namespace | UploaderLicenseException Constructor Overload List


UploaderLicenseException Constructor (SerializationInfo, StreamingContext)

[Visual Basic]
Overloads Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
protected UploaderLicenseException(
SerializationInfo info,
StreamingContext context
);
See Also

UploaderLicenseException Class | CuteWebUI Namespace | UploaderLicenseException Constructor Overload List


UploaderLicenseException Members

UploaderLicenseException overview

Public Instance Constructors
UploaderLicenseException Overloaded. Initializes a new instance of the UploaderLicenseException class.
Public Instance Properties
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
LicenseType
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)
Public Instance Methods
Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData
GetType (inherited from Object)
ToString (inherited from Exception)
Protected Instance Constructors
UploaderLicenseException Overloaded. Initializes a new instance of the UploaderLicenseException class.
Protected Instance Properties
HResult (inherited from Exception)
Protected Instance Methods
Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
See Also

UploaderLicenseException Class | CuteWebUI Namespace


UploaderLicenseProvider Class

UploaderLicenseProvider

For a list of all members of this type, see UploaderLicenseProvider Members.

System.Object
System.ComponentModel.LicenseProvider
CuteWebUI.UploaderLicenseProvider

[Visual Basic]
Public Class UploaderLicenseProvider
Inherits LicenseProvider
[C#]
public class UploaderLicenseProvider : LicenseProvider

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

UploaderLicenseProvider Members | CuteWebUI Namespace


UploaderLicenseProvider.GetLicense Method

[Visual Basic]
Overrides Public Function GetLicense( _
ByVal context As LicenseContext, _
ByVal type As Type, _
ByVal instance As Object, _
ByVal allowExceptions As Boolean _
) As License
[C#]
public override License GetLicense(
LicenseContext context,
Type type,
object instance,
bool allowExceptions
);
See Also

UploaderLicenseProvider Class | CuteWebUI Namespace


UploaderLicenseProvider Constructor

Initializes a new instance of the UploaderLicenseProvider class.

[Visual Basic]
Public Sub New()
[C#]
public UploaderLicenseProvider();
See Also

UploaderLicenseProvider Class | CuteWebUI Namespace


UploaderLicenseProvider Members

UploaderLicenseProvider overview

Public Instance Constructors
UploaderLicenseProvider Constructor Initializes a new instance of the UploaderLicenseProvider class.
Public Instance Methods
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetLicense
GetType (inherited from Object)
ToString (inherited from Object)
Protected Instance Methods
Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
See Also

UploaderLicenseProvider Class | CuteWebUI Namespace


UploaderProvider Class

This abstract class represents a Uploader Provider object.

For a list of all members of this type, see UploaderProvider Members.

System.Object
CuteWebUI.UploaderProvider

[Visual Basic]
MustInherit Public Class UploaderProvider
Implements IDisposable
[C#]
public abstract class UploaderProvider : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

UploaderProvider Members | CuteWebUI Namespace


UploaderProvider.AppendData Method

[Visual Basic]
MustOverride Public Sub AppendData( _
ByVal guid As Guid, _
ByVal filename As String, _
ByVal stream As Stream _
)
[C#]
public abstract void AppendData(
Guid guid,
string filename,
Stream stream
);
See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.CopyTo Method

[Visual Basic]
Overridable Public Sub CopyTo( _
ByVal fileguid As Guid, _
ByVal newpath As String _
)
[C#]
public virtual void CopyTo(
Guid fileguid,
string newpath
);
See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.Delete Method

Deletes the specified uploader.

[Visual Basic]
MustOverride Public Sub Delete( _
ByVal guid As Guid _
)
[C#]
public abstract void Delete(
Guid guid
);
Parameters
guid
The GUID.
See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

[Visual Basic]
Overridable Public Sub Dispose() _
Implements IDisposable.Dispose
[C#]
public virtual void Dispose();
Implements

IDisposable.Dispose

See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.Exists Method

Returns a boolean indicating whether or not the file exists

[Visual Basic]
Public Function Exists( _
ByVal guid As Guid _
) As Boolean
[C#]
public bool Exists(
Guid guid
);
Parameters
guid
The GUID.
Return Value

See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.GetFSPath Method

Gets the file system path.

[Visual Basic]
MustOverride Public Function GetFSPath( _
ByVal guid As Guid _
) As String
[C#]
public abstract string GetFSPath(
Guid guid
);
Parameters
guid
The GUID.
Return Value

See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.GetInfo Method

Gets the information of the specified uploader.

[Visual Basic]
MustOverride Public Function GetInfo( _
ByVal guid As Guid, _
ByRef filename As String, _
ByRef filesize As Integer, _
ByRef persist As Boolean _
) As Boolean
[C#]
public abstract bool GetInfo(
Guid guid,
out string filename,
out int filesize,
out bool persist
);
Parameters
guid
The GUID.
filename
The filename.
filesize
The filesize.
persist
if set to true [persist].
Return Value

See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.GetName Method

Gets the file name.

[Visual Basic]
Public Function GetName( _
ByVal guid As Guid _
) As String
[C#]
public string GetName(
Guid guid
);
Parameters
guid
The GUID.
Return Value

See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.GetSize Method

Gets the file size.

[Visual Basic]
Public Function GetSize( _
ByVal guid As Guid _
) As Integer
[C#]
public int GetSize(
Guid guid
);
Parameters
guid
The GUID.
Return Value

See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.Init Method

Inits the specified uploader.

[Visual Basic]
MustOverride Public Sub Init( _
ByVal uploader As UploaderBase, _
ByVal context As HttpContext _
)
[C#]
public abstract void Init(
UploaderBase uploader,
HttpContext context
);
Parameters
uploader
The uploader.
context
The context.
See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.Maintain Method

Maintains this instance.

[Visual Basic]
Overridable Public Sub Maintain()
[C#]
public virtual void Maintain();
See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.MoveTo Method

[Visual Basic]
Overridable Public Sub MoveTo( _
ByVal fileguid As Guid, _
ByVal newpath As String _
)
[C#]
public virtual void MoveTo(
Guid fileguid,
string newpath
);
See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.OpenStream Method

Opens the stream.

[Visual Basic]
MustOverride Public Function OpenStream( _
ByVal guid As Guid _
) As Stream
[C#]
public abstract Stream OpenStream(
Guid guid
);
Parameters
guid
The GUID.
Return Value

See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.Persist Method

Persists the specified uploader.

[Visual Basic]
MustOverride Public Sub Persist( _
ByVal guid As Guid _
)
[C#]
public abstract void Persist(
Guid guid
);
Parameters
guid
The GUID.
See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.Save Method (Guid, String, String)

Saves the specified uploader.

[Visual Basic]
Overridable Overloads Public Sub Save( _
ByVal guid As Guid, _
ByVal filename As String, _
ByVal temppath As String _
)
[C#]
public virtual void Save(
Guid guid,
string filename,
string temppath
);
Parameters
guid
The GUID.
filename
The filename.
temppath
The temppath.
See Also

UploaderProvider Class | CuteWebUI Namespace | UploaderProvider.Save Overload List


UploaderProvider.Save Method (Guid, String, Stream)

Saves the specified uploader.

[Visual Basic]
MustOverride Overloads Public Sub Save( _
ByVal guid As Guid, _
ByVal filename As String, _
ByVal stream As Stream _
)
[C#]
public abstract void Save(
Guid guid,
string filename,
Stream stream
);
Parameters
guid
The GUID.
filename
The filename.
stream
The stream.
See Also

UploaderProvider Class | CuteWebUI Namespace | UploaderProvider.Save Overload List


Save Method

PHP File Uploader Class Reference

UploaderProvider.Save Method

Saves the specified uploader.

Overload List

Saves the specified uploader.

public abstract void Save(Guid,string,Stream);

Saves the specified uploader.

public virtual void Save(Guid,string,string);
See Also

UploaderProvider Class | CuteWebUI Namespace


SupportFS Property

PHP File Uploader Class Reference

UploaderProvider.SupportFS Property

Gets a bool value indicating the file system is supported or not.

[Visual Basic]
MustOverride Public ReadOnly Property SupportFS As Boolean
[C#]
public abstract bool SupportFS {get;}

Property Value

true if [support FS]; otherwise, false.

See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider.UnPersist Method

Persists the specified uploader.

[Visual Basic]
MustOverride Public Sub UnPersist( _
ByVal guid As Guid _
)
[C#]
public abstract void UnPersist(
Guid guid
);
Parameters
guid
The GUID.
See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider Constructor

Initializes a new instance of the UploaderProvider class.

[Visual Basic]
Protected Sub New()
[C#]
protected UploaderProvider();
See Also

UploaderProvider Class | CuteWebUI Namespace


UploaderProvider Members

UploaderProvider overview

Public Instance Properties
SupportFS Gets a bool value indicating the file system is supported or not.
Public Instance Methods
AppendData |
CopyTo |
Delete | Deletes the specified uploader.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) |
Exists | Returns a boolean indicating whether or not the file exists
GetFSPath | Gets the file system path.
GetHashCode (inherited from Object) |
GetInfo | Gets the information of the specified uploader.
GetName | Gets the file name.
GetSize | Gets the file size.
GetType (inherited from Object) |
Init | Inits the specified uploader.
Maintain | Maintains this instance.
MoveTo |
OpenStream | Opens the stream.
Persist | Persists the specified uploader.
Save | Overloaded. Saves the specified uploader.
ToString (inherited from Object) |
UnPersist | Persists the specified uploader.
Protected Instance Constructors
UploaderProvider Constructor Initializes a new instance of the UploaderProvider class.
Protected Instance Methods
Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
See Also

UploaderProvider Class | CuteWebUI Namespace


UploadFileBase Class

Represents an UploadFileBase object.

For a list of all members of this type, see UploadFileBase Members.

System.Object
System.Web.UI.Control
CuteWebUI.UploaderBase
CuteWebUI.Uploader
CuteWebUI.UploadFileBase
CuteWebUI.UploadAttachments
CuteWebUI.UploadPersistedFile

[Visual Basic]
MustInherit Public Class UploadFileBase
Inherits Uploader
[C#]
public abstract class UploadFileBase : Uploader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

UploadFileBase Members | CuteWebUI Namespace


UploadFileBase._itemLabelStyle Field

[Visual Basic]
Protected Friend _itemLabelStyle As Style
[C#]
protected internal Style _itemLabelStyle;

See Also

UploadFileBase Class | CuteWebUI Namespace


DirtyText Property

PHP File Uploader Class Reference

UploadFileBase.DirtyText Property

Gets or sets the dirty text.

[Visual Basic]
Public Property DirtyText As String
[C#]
public string DirtyText {get; set;}

Property Value

The dirty text.

See Also

UploadFileBase Class | CuteWebUI Namespace


ItemLabelStyle Property

PHP File Uploader Class Reference

UploadFileBase.ItemLabelStyle Property

Gets the item label style.

[Visual Basic]
Public ReadOnly Property ItemLabelStyle As Style
[C#]
public System.Web.UI.WebControls.Style ItemLabelStyle {get;}

Property Value

The item label style.

See Also

UploadFileBase Class | CuteWebUI Namespace


ItemTextTemplate Property

PHP File Uploader Class Reference

UploadFileBase.ItemTextTemplate Property

Gets or sets the item text template.

[Visual Basic]
Public Property ItemTextTemplate As String
[C#]
public string ItemTextTemplate {get; set;}

Property Value

The item text template.

See Also

UploadFileBase Class | CuteWebUI Namespace


UploadFileBase.LoadViewState Method

[Visual Basic]
Overrides Protected Sub LoadViewState( _
ByVal savedState As Object _
)
[C#]
protected override void LoadViewState(
object savedState
);
See Also

UploadFileBase Class | CuteWebUI Namespace


UploadFileBase.SaveViewState Method

[Visual Basic]
Overrides Protected Function SaveViewState() As Object
[C#]
protected override object SaveViewState();
See Also

UploadFileBase Class | CuteWebUI Namespace


UploadFileBase.TrackViewState Method

[Visual Basic]
Overrides Protected Sub TrackViewState()
[C#]
protected override void TrackViewState();
See Also

UploadFileBase Class | CuteWebUI Namespace


UploadFileBase Constructor

Initializes a new instance of the UploadFileBase class.

[Visual Basic]
Protected Sub New()
[C#]
protected UploadFileBase();
See Also

UploadFileBase Class | CuteWebUI Namespace


UploadFileBase Members

UploadFileBase overview

Public Instance Properties
AutoUseSystemTempFolder (inherited from UploaderBase) | A system temporary folder or temporary directory is a directory used to hold temporary files. By default, when PHP File Uploader detects TempDirectory propery is not set, it will automatically use the system temporary folder. if web.config sepcified the TempDirectory appSetting, this would not take effects. You can turn this feature off by setting it to "false".
BindingContainer (inherited from Control) |
ButtonOnClickScript (inherited from UploaderBase) | JavaScript code that be executed when the browse button be clicked.
CancelAllMsg (inherited from UploaderBase) | Gets or sets the "Cancel all Uploads" message.
CancelButton (inherited from Uploader) |
CancelButtonID (inherited from UploaderBase) | It allows the developers specify a server control to use as the cancel button of PHP File Uploader.
CancelButtonStyle (inherited from Uploader) | Gets the cancel button style.
CancelText (inherited from Uploader) | Gets or sets the cancel text.
CancelUploadMsg (inherited from UploaderBase) | Gets or sets the "Cancel upload" message.
ClientID (inherited from Control) |
Controls (inherited from Control) |
DialogFilter (inherited from UploaderBase) | Gets or sets the current file name filter string, which determines the choices that appear in the file browser dialog box. Please note that only ValidateOption.AllowedFileExtensions property determine the allowed file extensions for uploading.
DirtyText | Gets or sets the dirty text.
EnableViewState (inherited from Control) |
FileTooLargeMsg (inherited from UploaderBase) | Gets or sets the "File too large" message.
FileTypeNotSupportMsg (inherited from UploaderBase) | Gets or sets the "file type not support" message.
FlashUploadPage (inherited from UploaderBase) | set a special page for Flash - Integrated Windows Authentication chould be also set to web.config appSettings : CuteWebUI.AjaxUploader.FlashUploadPage (CuteEditor.AjaxUploader.FlashUploadPage for CuteEditor)
FlashWarningImage (inherited from UploaderBase) | Gets or sets the FlashWarning Image.
ID (inherited from Control) |
InputboxCSSText (inherited from UploaderBase) | Sets or retrieves the appearance of the file input control.
InsertButton (inherited from Uploader) |
InsertButtonID (inherited from UploaderBase) | It allows the developers specify a server control to use as the insert button of PHP File Uploader.
InsertButtonStyle (inherited from Uploader) | Gets the insert button style.
InsertText (inherited from Uploader) | Gets or sets the insert text.
ItemLabelStyle | Gets the item label style.
ItemTextTemplate | Gets or sets the item text template.
ManualStartUpload (inherited from UploaderBase) | Gets or sets a boolean indicating whether Uploader automatically starts uploading as soon as a user selects a file.
MaxFilesLimit (inherited from UploaderBase) | Gets or sets the maximum number of files that can be uploaded.
MaxFilesLimitMsg (inherited from UploaderBase) | Gets or sets the "File too large" message.
MultipleFilesUpload (inherited from UploaderBase) | If true, the users are able to select multiple files in the file browser dialog then upload them at once.
NamingContainer (inherited from Control) |
NumFilesShowCancelAll (inherited from UploaderBase) |
Page (inherited from Control) |
Parent (inherited from Control) |
ProgressBarBackgroundImage (inherited from UploaderBase) | Gets or sets the background image for the ProgressBar control.
ProgressBarBorderStyle (inherited from UploaderBase) | Specifies the border style for the ProgressBar control.
ProgressBarHeight (inherited from UploaderBase) | The height of the Progress bar. Default is 15.
ProgressBarStyle (inherited from UploaderBase) | Specifies the style that a ProgressBar uses to indicate the progress of an operation.
ProgressCtrlID (inherited from UploaderBase) | It allows the developers specify a server control to use as the progress control of PHP File Uploader.
ProgressInfoStyle (inherited from UploaderBase) | The style to be applied to the progress information.
ProgressLabel (inherited from Uploader) |
ProgressLabelStyle (inherited from Uploader) | Gets the progress label style.
ProgressPanel (inherited from Uploader) |
ProgressPanelStyle (inherited from Uploader) | Gets the progress panel style.
ProgressPanelWidth (inherited from UploaderBase) | The width of the Progress Panel. Default is 500.
ProgressPicture (inherited from UploaderBase) | Gets or sets a progress fill picture for the ProgressBar control.
ProgressTextID (inherited from UploaderBase) | It allows the developers specify a server control to show the progress text of PHP File Uploader.
ProgressTextTemplate (inherited from UploaderBase) | Gets or sets the progress text template. %P% = percent,%T% = seconds remain,%F% = filename. %SEND% = uploaded size , %SIZE% = file size , %KBPS% means KB/s , %KBPS% = B/s For example : %F%.. %P% %SEND%/%SIZE% , %KBPS% , %T% seconds left.
ShowFrameBrowseButton (inherited from UploaderBase) | Gets or sets a boolean indicating whether Uploader should render a browse button for FireFox/Opera in Iframe Mode.
ShowProgressBar (inherited from UploaderBase) | Gets or sets a value indicating whether the progress bar is displayed. The UploadModule must be installed to use this feature.
ShowProgressInfo (inherited from UploaderBase) | Gets or sets a value indicating whether the progress information is displayed when uploading. The UploadModule must be installed to use this feature.
Site (inherited from Control) |
TempDirectory (inherited from UploaderBase) | Specifies where AjaxUploader should put the temporary files.
TemplateSourceDirectory (inherited from Control) |
UniqueID (inherited from Control) |
UploadingMsg (inherited from UploaderBase) | Gets or sets the "Uploading.." message.
UploadProcessingMsg (inherited from UploaderBase) | Gets or sets the "upload is processing" message.
UploadType (inherited from UploaderBase) | The global type of upload method to use.
ValidateOption (inherited from UploaderBase) | Gets the validate option.
Visible (inherited from Control) |
WindowsDialogLimitMsg (inherited from UploaderBase) | Gets or sets the message for windows file browse dialog 32K file name length limitation.
Public Instance Methods
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) | Overloaded.
GetAdvancedOption (inherited from UploaderBase) | Overloaded.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GetUploaderProvider (inherited from UploaderBase) | Gets the uploader provider instance to handle file data.
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetAdvancedOption (inherited from UploaderBase) | Overloaded.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |
Upload (inherited from UploaderBase) | Overloaded. Use server file to simulate file uploading and uploaded event. This method affects all child types.
Public Instance Events
DataBinding (inherited from Control) |
Disposed (inherited from Control) |
FileUploaded (inherited from UploaderBase) | fired when a file are uploaded and validated
FileValidating (inherited from UploaderBase) | attach custom code to validate the uploading file
Init (inherited from Control) |
Load (inherited from Control) |
PreRender (inherited from Control) |
Unload (inherited from Control) |
Protected Instance Constructors
UploadFileBase Constructor Initializes a new instance of the UploadFileBase class.
Protected Instance Properties
ChildControlsCreated (inherited from Control) |
Context (inherited from Control) |
Events (inherited from Control) |
HasChildViewState (inherited from Control) |
IsBrowserSupportUploadScript (inherited from UploaderBase) | detect whether the browser support the script upload
IsDesignMode (inherited from UploaderBase) |
IsTrackingViewState (inherited from Control) |
ViewState (inherited from Control) |
ViewStateIgnoresCase (inherited from Control) |
Protected Instance Methods
AddControlIDToAttribute (inherited from Uploader) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) | Overloaded.
GetAdvancedOption (inherited from UploaderBase) | Overloaded.
GetUploadedFileCount (inherited from UploaderBase) |
IsLiteralContent (inherited from Control) |
LoadViewState |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnFileUploaded (inherited from UploaderBase) |
OnFileValidating (inherited from UploaderBase) |
OnInit (inherited from UploaderBase) |
OnLoad (inherited from UploaderBase) |
OnPreRender (inherited from UploaderBase) | OnPreRender
OnUnload (inherited from UploaderBase) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from Uploader) |
RenderChildren (inherited from Uploader) |
RenderDesignMode (inherited from Uploader) |
RenderInsertButton (inherited from Uploader) |
RenderProgressCtrl (inherited from Uploader) |
SaveViewState |
SetAdvancedOption (inherited from UploaderBase) | Overloaded.
TrackViewState |
Protected Internal Instance Fields
_itemLabelStyle
Protected Internal Instance Methods
AddedControl (inherited from Control)
RemovedControl (inherited from Control)
See Also

UploadFileBase Class | CuteWebUI Namespace


UploadModule Class

This class represents an Upload Module object.

For a list of all members of this type, see UploadModule Members.

System.Object
CuteWebUI.UploadModule

[Visual Basic]
Public Class UploadModule
Implements IHttpModule
[C#]
public class UploadModule : IHttpModule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

UploadModule Members | CuteWebUI Namespace


UploadModule.HandleAddonUpload Method

a public method to handle the flash/silverlight mode upload of IHttpHandler.

[Visual Basic]
Public Shared Function HandleAddonUpload( _
ByVal context As HttpContext _
) As Boolean
[C#]
public static bool HandleAddonUpload(
HttpContext context
);
See Also

UploadModule Class | CuteWebUI Namespace


UploadModule.HandleResource Method

process the resources.

[Visual Basic]
Public Shared Function HandleResource( _
ByVal context As HttpContext _
) As Boolean
[C#]
public static bool HandleResource(
HttpContext context
);
See Also

UploadModule Class | CuteWebUI Namespace


LimitSpeedForTest Property

PHP File Uploader Class Reference

UploadModule.LimitSpeedForTest Property

Gets a value indicating whether [limit upload speed for test].

[Visual Basic]
Public Shared ReadOnly Property LimitSpeedForTest As Boolean
[C#]
public static bool LimitSpeedForTest {get;}

Property Value

true if [limit speed for test]; otherwise, false.

See Also

UploadModule Class | CuteWebUI Namespace


UploadModuleSkipKB Property

PHP File Uploader Class Reference

UploadModule.UploadModuleSkipKB Property

Gets the upload module skip KB.

[Visual Basic]
Public Shared ReadOnly Property UploadModuleSkipKB As Integer
[C#]
public static int UploadModuleSkipKB {get;}

Property Value

The upload module skip KB.

See Also

UploadModule Class | CuteWebUI Namespace


UploadModule Constructor

Initializes a new instance of the UploadModule class.

[Visual Basic]
Public Sub New()
[C#]
public UploadModule();
See Also

UploadModule Class | CuteWebUI Namespace


UploadModule Members

UploadModule overview

Public Static (Shared) Properties
LimitSpeedForTest | Gets a value indicating whether [limit upload speed for test].
UploadModuleSkipKB | Gets the upload module skip KB.
Public Static (Shared) Methods
HandleAddonUpload | a public method to handle the flash/silverlight mode upload of IHttpHandler.
HandleResource | process the resources.
Public Instance Constructors
UploadModule Constructor Initializes a new instance of the UploadModule class.
Public Instance Methods
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)
Protected Instance Methods
Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
See Also

UploadModule Class | CuteWebUI Namespace


UploadPersistedFile Class

This class represents an enhanced control for uploading files to the server. The object can persist across postbacks.

For a list of all members of this type, see UploadPersistedFile Members.

System.Object
System.Web.UI.Control
CuteWebUI.UploaderBase
CuteWebUI.Uploader
CuteWebUI.UploadFileBase
CuteWebUI.UploadPersistedFile

[Visual Basic]
Public Class UploadPersistedFile
Inherits UploadFileBase
[C#]
public class UploadPersistedFile : UploadFileBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

UploadPersistedFile Members | CuteWebUI Namespace


UploadPersistedFile.ChangeFire Method

Changes the fire.

[Visual Basic]
Public Sub ChangeFire( _
ByVal filesize As Integer, _
ByVal filename As String, _
ByVal stream As Stream _
)
[C#]
public void ChangeFire(
int filesize,
string filename,
Stream stream
);
Parameters
filesize
The filesize.
filename
The filename.
stream
The stream.
See Also

UploadPersistedFile Class | CuteWebUI Namespace


File Property

PHP File Uploader Class Reference

UploadPersistedFile.File Property

Get an object which contains the uploaded file. The object can persist across postbacks.

[Visual Basic]
Public ReadOnly Property File As PersistedFile
[C#]
public PersistedFile File {get;}

Property Value

The file.

See Also

UploadPersistedFile Class | CuteWebUI Namespace


UploadPersistedFile.FileChanged Event

Occurs when a file is uploaded and the .File property is changed

[Visual Basic]
Public Event FileChanged As PersistedFileEventHandler
[C#]
public event PersistedFileEventHandler FileChanged;

Event Data

The event handler receives an argument of type PersistedFileEventArgs containing data related to this event. The following PersistedFileEventArgs properties provide information specific to this event.

Property | Description
File | Gets the file.
FileGuid | Gets the GUID of the file.
FileName | Gets the name of the file.
FileSize | Gets the size of the file.
See Also

UploadPersistedFile Class | CuteWebUI Namespace


UploadPersistedFile.GetUploadedFileCount Method

[Visual Basic]
Overrides Protected Function GetUploadedFileCount() As Integer
[C#]
protected override int GetUploadedFileCount();
See Also

UploadPersistedFile Class | CuteWebUI Namespace


UploadPersistedFile.OnFileChanged Method

Raises the FileChanged event.

[Visual Basic]
Overridable Protected Sub OnFileChanged( _
ByVal args As PersistedFileEventArgs _
)
[C#]
protected virtual void OnFileChanged(
PersistedFileEventArgs args
);
Parameters
args
The PersistedFileEventArgs instance containing the event data.
See Also

UploadPersistedFile Class | CuteWebUI Namespace


UploadPersistedFile.OnFileUploaded Method

Raises the FileUploaded event.

[Visual Basic]
Overrides Protected Sub OnFileUploaded( _
ByVal args As PhpUploadFile _
)
[C#]
protected override void OnFileUploaded(
PhpUploadFile args
);
Parameters
args
The PhpUploadFile instance containing the event data.
See Also

UploadPersistedFile Class | CuteWebUI Namespace


UploadPersistedFile.RenderDesignMode Method

[Visual Basic]
Overrides Protected Sub RenderDesignMode( _
ByVal writer As HtmlTextWriter _
)
[C#]
protected override void RenderDesignMode(
HtmlTextWriter writer
);
See Also

UploadPersistedFile Class | CuteWebUI Namespace


UploadPersistedFile.RenderInsertButton Method

[Visual Basic]
Overrides Protected Sub RenderInsertButton( _
ByVal writer As HtmlTextWriter _
)
[C#]
protected override void RenderInsertButton(
HtmlTextWriter writer
);
See Also

UploadPersistedFile Class | CuteWebUI Namespace


UploadPersistedFile Constructor

Initializes a new instance of the UploadPersistedFile class.

[Visual Basic]
Public Sub New()
[C#]
public UploadPersistedFile();
See Also

UploadPersistedFile Class | CuteWebUI Namespace


UploadPersistedFile Members

UploadPersistedFile overview

Public Instance Constructors
UploadPersistedFile Constructor Initializes a new instance of the UploadPersistedFile class.
Public Instance Properties
AutoUseSystemTempFolder (inherited from UploaderBase) | A system temporary folder or temporary directory is a directory used to hold temporary files. By default, when PHP File Uploader detects TempDirectory propery is not set, it will automatically use the system temporary folder. if web.config sepcified the TempDirectory appSetting, this would not take effects. You can turn this feature off by setting it to "false".
BindingContainer (inherited from Control) |
ButtonOnClickScript (inherited from UploaderBase) | JavaScript code that be executed when the browse button be clicked.
CancelAllMsg (inherited from UploaderBase) | Gets or sets the "Cancel all Uploads" message.
CancelButton (inherited from Uploader) |
CancelButtonID (inherited from UploaderBase) | It allows the developers specify a server control to use as the cancel button of PHP File Uploader.
CancelButtonStyle (inherited from Uploader) | Gets the cancel button style.
CancelText (inherited from Uploader) | Gets or sets the cancel text.
CancelUploadMsg (inherited from UploaderBase) | Gets or sets the "Cancel upload" message.
ClientID (inherited from Control) |
Controls (inherited from Control) |
DialogFilter (inherited from UploaderBase) | Gets or sets the current file name filter string, which determines the choices that appear in the file browser dialog box. Please note that only ValidateOption.AllowedFileExtensions property determine the allowed file extensions for uploading.
DirtyText (inherited from UploadFileBase) | Gets or sets the dirty text.
EnableViewState (inherited from Control) |
File | Get an object which contains the uploaded file. The object can persist across postbacks.
FileTooLargeMsg (inherited from UploaderBase) | Gets or sets the "File too large" message.
FileTypeNotSupportMsg (inherited from UploaderBase) | Gets or sets the "file type not support" message.
FlashUploadPage (inherited from UploaderBase) | set a special page for Flash - Integrated Windows Authentication chould be also set to web.config appSettings : CuteWebUI.AjaxUploader.FlashUploadPage (CuteEditor.AjaxUploader.FlashUploadPage for CuteEditor)
FlashWarningImage (inherited from UploaderBase) | Gets or sets the FlashWarning Image.
ID (inherited from Control) |
InputboxCSSText (inherited from UploaderBase) | Sets or retrieves the appearance of the file input control.
InsertButton (inherited from Uploader) |
InsertButtonID (inherited from UploaderBase) | It allows the developers specify a server control to use as the insert button of PHP File Uploader.
InsertButtonStyle (inherited from Uploader) | Gets the insert button style.
InsertText (inherited from Uploader) | Gets or sets the insert text.
ItemLabelStyle (inherited from UploadFileBase) | Gets the item label style.
ItemTextTemplate (inherited from UploadFileBase) | Gets or sets the item text template.
ManualStartUpload (inherited from UploaderBase) | Gets or sets a boolean indicating whether Uploader automatically starts uploading as soon as a user selects a file.
MaxFilesLimit (inherited from UploaderBase) | Gets or sets the maximum number of files that can be uploaded.
MaxFilesLimitMsg (inherited from UploaderBase) | Gets or sets the "File too large" message.
MultipleFilesUpload (inherited from UploaderBase) | If true, the users are able to select multiple files in the file browser dialog then upload them at once.
NamingContainer (inherited from Control) |
NumFilesShowCancelAll (inherited from UploaderBase) |
Page (inherited from Control) |
Parent (inherited from Control) |
ProgressBarBackgroundImage (inherited from UploaderBase) | Gets or sets the background image for the ProgressBar control.
ProgressBarBorderStyle (inherited from UploaderBase) | Specifies the border style for the ProgressBar control.
ProgressBarHeight (inherited from UploaderBase) | The height of the Progress bar. Default is 15.
ProgressBarStyle (inherited from UploaderBase) | Specifies the style that a ProgressBar uses to indicate the progress of an operation.
ProgressCtrlID (inherited from UploaderBase) | It allows the developers specify a server control to use as the progress control of PHP File Uploader.
ProgressInfoStyle (inherited from UploaderBase) | The style to be applied to the progress information.
ProgressLabel (inherited from Uploader) |
ProgressLabelStyle (inherited from Uploader) | Gets the progress label style.
ProgressPanel (inherited from Uploader) |
ProgressPanelStyle (inherited from Uploader) | Gets the progress panel style.
ProgressPanelWidth (inherited from UploaderBase) | The width of the Progress Panel. Default is 500.
ProgressPicture (inherited from UploaderBase) | Gets or sets a progress fill picture for the ProgressBar control.
ProgressTextID (inherited from UploaderBase) | It allows the developers specify a server control to show the progress text of PHP File Uploader.
ProgressTextTemplate (inherited from UploaderBase) | Gets or sets the progress text template. %P% = percent,%T% = seconds remain,%F% = filename. %SEND% = uploaded size , %SIZE% = file size , %KBPS% means KB/s , %KBPS% = B/s For example : %F%.. %P% %SEND%/%SIZE% , %KBPS% , %T% seconds left.
ShowFrameBrowseButton (inherited from UploaderBase) | Gets or sets a boolean indicating whether Uploader should render a browse button for FireFox/Opera in Iframe Mode.
ShowProgressBar (inherited from UploaderBase) | Gets or sets a value indicating whether the progress bar is displayed. The UploadModule must be installed to use this feature.
ShowProgressInfo (inherited from UploaderBase) | Gets or sets a value indicating whether the progress information is displayed when uploading. The UploadModule must be installed to use this feature.
Site (inherited from Control) |
TempDirectory (inherited from UploaderBase) | Specifies where AjaxUploader should put the temporary files.
TemplateSourceDirectory (inherited from Control) |
UniqueID (inherited from Control) |
UploadingMsg (inherited from UploaderBase) | Gets or sets the "Uploading.." message.
UploadProcessingMsg (inherited from UploaderBase) | Gets or sets the "upload is processing" message.
UploadType (inherited from UploaderBase) | The global type of upload method to use.
ValidateOption (inherited from UploaderBase) | Gets the validate option.
Visible (inherited from Control) |
WindowsDialogLimitMsg (inherited from UploaderBase) | Gets or sets the message for windows file browse dialog 32K file name length limitation.
Public Instance Methods
ChangeFire | Changes the fire.
DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) |
FindControl (inherited from Control) | Overloaded.
GetAdvancedOption (inherited from UploaderBase) | Overloaded.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
GetUploaderProvider (inherited from UploaderBase) | Gets the uploader provider instance to handle file data.
HasControls (inherited from Control) |
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetAdvancedOption (inherited from UploaderBase) | Overloaded.
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) |
Upload (inherited from UploaderBase) | Overloaded. Use server file to simulate file uploading and uploaded event. This method affects all child types.
Public Instance Events
DataBinding (inherited from Control) |
Disposed (inherited from Control) |
FileChanged | Occurs when a file is uploaded and the .File property is changed
FileUploaded (inherited from UploaderBase) | fired when a file are uploaded and validated
FileValidating (inherited from UploaderBase) | attach custom code to validate the uploading file
Init (inherited from Control) |
Load (inherited from Control) |
PreRender (inherited from Control) |
Unload (inherited from Control) |
Protected Instance Properties
ChildControlsCreated (inherited from Control) |
Context (inherited from Control) |
Events (inherited from Control) |
HasChildViewState (inherited from Control) |
IsBrowserSupportUploadScript (inherited from UploaderBase) | detect whether the browser support the script upload
IsDesignMode (inherited from UploaderBase) |
IsTrackingViewState (inherited from Control) |
ViewState (inherited from Control) |
ViewStateIgnoresCase (inherited from Control) |
Protected Instance Methods
AddControlIDToAttribute (inherited from Uploader) |
AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls (inherited from Control) |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) |
FindControl (inherited from Control) | Overloaded.
GetAdvancedOption (inherited from UploaderBase) | Overloaded.
GetUploadedFileCount |
IsLiteralContent (inherited from Control) |
LoadViewState (inherited from UploadFileBase) |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) |
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnFileChanged | Raises the FileChanged event.
OnFileUploaded | Raises the FileUploaded event.
OnFileValidating (inherited from UploaderBase) |
OnInit (inherited from UploaderBase) |
OnLoad (inherited from UploaderBase) |
OnPreRender (inherited from UploaderBase) | OnPreRender
OnUnload (inherited from UploaderBase) |
RaiseBubbleEvent (inherited from Control) |
Render (inherited from Uploader) |
RenderChildren (inherited from Uploader) |
RenderDesignMode |
RenderInsertButton |
RenderProgressCtrl (inherited from Uploader) |
SaveViewState (inherited from UploadFileBase) |
SetAdvancedOption (inherited from UploaderBase) | Overloaded.
TrackViewState (inherited from UploadFileBase) |
Protected Internal Instance Fields
_itemLabelStyle (inherited from UploadFileBase)
Protected Internal Instance Methods
AddedControl (inherited from Control)
RemovedControl (inherited from Control)
See Also

UploadPersistedFile Class | CuteWebUI Namespace


UploadType Enumeration

The global type of upload method to use.

[Visual Basic]
Public Enum UploadType
[C#]
public enum UploadType
Members
Member Name | Description
Auto | Determines browser capabilities and chooses the most appropriate method to upload.
Flash | Uses an enhanced file dialog facilitated by a Flash object.
Silverlight | Uses an enhanced file dialog facilitated by a Silverlight object.
IFrame | Uses a standard IFrame technique to provide upload functionality without requiring the Flash/Silverlight plugin.
Requirements

Namespace: CuteWebUI

Assembly: CuteWebUI.AjaxUploader (in CuteWebUI.AjaxUploader.dll)

See Also

CuteWebUI Namespace


CuteWebUIHierarchy

PHP File Uploader Class Reference

CuteWebUI Hierarchy

System.Object
CuteWebUI.AttachmentItemCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
CuteWebUI.AttachmentItemEventArgs
CuteWebUI.IAttachmentProvider
CuteWebUI.PersistedFile
CuteWebUI.PhpUploadFile
CuteWebUI.PersistedFileEventArgs
CuteWebUI.UploaderProvider ---- System.IDisposable
CuteWebUI.UploaderValidateOption
CuteWebUI.UploadModule ---- System.Web.IHttpModule
System.ComponentModel.LicenseProvider
CuteWebUI.UploaderLicenseProvider
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
CuteWebUI.AttachmentItemEventHandler
CuteWebUI.PersistedFileEventHandler
CuteWebUI.UploaderEventHandler
System.Exception ---- System.Runtime.Serialization.ISerializable
CuteWebUI.UploaderLicenseException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
CuteWebUI.AttachmentItemBehavior
CuteWebUI.AttachmentItemTemplatePosition
CuteWebUI.EnumUploaderLicense
CuteWebUI.ProgressBarType
CuteWebUI.UploaderAdvancedOption
CuteWebUI.UploadType
System.Web.UI.Control ---- System.ComponentModel.IComponent, System.IDisposable, System.Web.UI.IDataBindingsAccessor, System.Web.UI.IParserAccessor
CuteWebUI.AttachmentItem ---- System.Web.UI.INamingContainer, System.Web.UI.IPostBackEventHandler
CuteWebUI.UploaderBase ---- System.Web.UI.IPostBackDataHandler, System.Web.UI.IPostBackEventHandler
CuteWebUI.Uploader ---- System.Web.UI.INamingContainer
CuteWebUI.UploadFileBase
CuteWebUI.UploadAttachments
CuteWebUI.UploadPersistedFile
See Also

CuteWebUI Namespace